Winchester Model 74

Discussion in '.22 Rifle/Rimfire Discussion' started by evo9guy, Apr 29, 2010.

  1. evo9guy

    evo9guy New Member

    8
    0
    0
    Hello all,

    Recently acquired a Model 74 from my dad, chambered in .22 LR, and I am having a problem with the bolt. I have not been able to find a schematic or a exploded parts view online (well one that is free anyway) and was wondering if anybody could help out with one.

    Or...

    The reason for the above request, the rifle will fire perfect; however, when loading the rifle with a round the bolt does not travel back far enough to charge the trigger. There will be a round in the chamber, but when you pull the trigger, nothing. Pull the charging handle again, out comes previous round, new round enters chamber, take aim, pull trigger, nothing. After about five or six tries the rifle will fire and from there wil go through the remaining rounds. When the rest of the rounds are done, the process starts all over again.

    I have a feeling it needs either the springs or firing pin or something replaced.

    ANY help is greatly appreciated.

    Thanks,
    Evo
     
    Last edited: Apr 29, 2010
  2. evo9guy

    evo9guy New Member

    8
    0
    0

  3. CA357

    CA357 New Member Supporter

    19,847
    4
    0
    I don't really have any idea. Have you removed the bolt and checked it? Perhaps give the rifle a good cleaning and lube? Maybe disassemble the bolt and take a look? Is there a burr or something in the breech area?
     
  4. evo9guy

    evo9guy New Member

    8
    0
    0
    I have removed the bolt and disassembled and cleaned. The action was better but still not 100%.
     
  5. CA357

    CA357 New Member Supporter

    19,847
    4
    0
    In that case, maybe it's time to take it to a gunsmith?