Trouble with Veriforce side rail scope mount

Discussion in 'AK & SKS Discussion' started by shenny, Feb 18, 2011.

  1. shenny

    shenny New Member

    26
    0
    0
    So I recently purchased an Arsenal SGL21, and it is sweet! I bought some cheap side rail scope mount, and, of course, it doesnt go down the center bore line. So i bought a Veriforce, the kind with the quick release clamp. Only problem is, it will NOT slide on! it seems that the slot is slightly narrower than the rail?! Anyone else run into this problem?

    I really appreciate ANY advice!
     
  2. RUT

    RUT New Member Supporter

    111
    0
    0
    If it's anything like the Kevar KV-04 it should have a spring loaded tension adjuster in the center. (backside) I just checked their website, and if it's the bottom one w/ QD lever, it's just like the one I have. Turn it over and diddle with the tension adjuster to the point where it just slides over the rail and allows you to close/lock the clamp. Check the "how to" video on the attached link.

    http://www.tacticalaccessories.com/products/viewproduct.php?id_product=208
     
    Last edited: Feb 19, 2011

  3. jpattersonnh

    jpattersonnh Active Member

    5,360
    5
    38
    There are 2 types of side rails, so there are 2 different mounts. Even w/ the correct side rail mount, I had to do a bit of fitting for it to slide on.
     
  4. shenny

    shenny New Member

    26
    0
    0
    Well...I know about the adjustment nut thingy. I adjusted. I wiggled. I even took it all the way off. No dice whatsoever. I can see where the channel is just hitting the rail, it ain't going on without some grinding or milling. I liked it but I had to send it back. Instead, I purchased this:

    Kalinka BP-02 AK/AKM Low Profile Centered Side Mount to Weaver Rail w/ Black Finish

    Lets hope this one fits. It IS sweet looking.

    Thanks for the help though guys! Two more responses than I got on the AK Files forum!