Taurus 66 side plate question

Discussion in 'Gunsmithing Forum' started by mudslinger79, Mar 20, 2011.

  1. mudslinger79

    mudslinger79 New Member

    258
    0
    0
    I have a Taurus 66 4 inch barrel, made in 1987. Im having an issue with getting the side plate back on. I will admit from what I've read I may have the screws messed up. They all appear to be the same length but I'm no gunsmith. If I lay the side plate on with the thing that rotates the cylinder no in the gun it lays great. If I put that in it lays funny. And when I tighten the screws I can't pull the trigger or cock the hammer. I have to back the screws out a bit at a time to relieve tension then its fine BUT at least one screw is very loose. WHAT AM I DOIN WRONG!?!?
     
  2. stalkingbear

    stalkingbear Well-Known Member

    4,094
    28
    48
    I've never had that problem. Can you take some close up pics? Are you sure you're installing the hand/pawl right?
     

  3. mudslinger79

    mudslinger79 New Member

    258
    0
    0
    I'm pretty sure I am. Ill try to get some pics soon. When I tighten the screws the trigger wont pull. If I start to back the screws out ut will move. If the screws are loose u can pull the trigger all day. If u start to tighten them up its ok till there nice and tight. Last night I tightened them untill it wouldn't pull, backed them out till I could then just barely started to move the screws back in. Then I got a sweet spot to wear it had trigger pull and the screws are semi tight. Only problem is on dry firing you can watch one of the screws move.