Shut The Front Door!

Discussion in 'Glock Forum' started by Glockpotion23, Feb 20, 2012.

  1. Glockpotion23

    Glockpotion23 New Member

    399
    0
    0
    Took my new G30 to the range today and was very disappointed needless to say. The problem my friend had the other day, i had the same today! I used the same ammo as before(federal) and after the first three rounds; the gun would jam. The first 25 rounds, it done it like three times. The other 25, like twice. Each time, i would eject the last two rounds, reload and fire. I love how she shoots but concerned about all the malfunctions. I am not sure what to do because my G23 works flawless. I have never used federal ammo with the 23 but started with the 30(gun shop guy said works better). With the 23 i used Winchester(white box) and some crappy Tulamo or something but fed every round. Can someone help troubleshoot this? do i need to send it to Glock?
     
  2. Charyoutree

    Charyoutree New Member

    84
    0
    0
    I had a similar problem with a friend's G17. A thorough cleaning and oiling at all the points suggested in the owner's manual did the trick and had it running like a machine.

    That being said, my (rather limited) experience is that Federal ammo is a LOT dirtier than WInchester White Box. Since I am still in the learning curve of handgun ownership, I have made it a point to clean my guns after every trip to the range. The times I've used Federal it has taken twice as many patches to clean the guns.

    Give the gun a thorough cleaning, make sure it is well lubricated, use cleaner ammo...and see if that helps.

    Just saying'....

    Quis custodiet ipsos custodes? (Who watches the watchers?) --"Satires", Juvenal (Roman poet)
     

  3. AgentTikki

    AgentTikki New Member

    3,496
    0
    0
    SO, you've only tried Federal in your G30? Is it Federal 230gr ball? I could just be your particular gun doesn't like that for some reason.

    Have you checked you feedramps? are you using the factory magazine? G21 magazine with Arrendondo or Pearce extentions?

    have your tried out any other ammo? Remington UMC, Winchester White Box?
     
  4. Glockpotion23

    Glockpotion23 New Member

    399
    0
    0
    I havent tried any other ammo yet but i think i will. I use factory mags too. Yup its the 230
     
  5. Hammy517

    Hammy517 New Member

    17
    0
    0
    I don't own a glock 30 but do have a 17, 19, 26 and don't have any problems. As far as Federal ammo being dirtier shouldnt make a difference IMO in a Glock. I have shot plenty of Federal ammo and feel its just fine. Glocks should not have this problem. I would send it in. Does not sound reliable.
     
  6. vincent

    vincent New Member

    4,123
    0
    0
    1-Mag issue? Non factory? Most feed issues are because of the mags.

    2-Feed ramp? Did you give it a swab before you shot? Factory grease maybe?

    3-Ammo...not likely, Glocks eat all ya feed 'em

    My .02, you have a mag thing going on...:cool:
     
  7. JTJ

    JTJ Well-Known Member Supporter

    9,677
    390
    83
    What kind of jam are you getting?
     
  8. Glockpotion23

    Glockpotion23 New Member

    399
    0
    0
    I think i may polish the feedramp after i clean the pistol.i may even strip the slide too. Should i try the federal again or switch brands?
     
  9. RogerH

    RogerH New Member

    81
    0
    0
    my glocks love umc the are less expencive just for 1000 9mm for 179 at bi mart. very clean shooting just a wipe down when done.
     
  10. FCross7

    FCross7 New Member

    1,015
    0
    0
    This ^^.

    Different kinds of malfunctions have very different causes.

    I've shot around 2000 rounds of Federal Champion in 9mm, and have never had an issue. Most of that is through Glocks (17,19 and 26). It's my brass practice ammo of choice.

    -Fred