Shell not ejecting

Discussion in 'General Shotgun Discussion' started by Vinnie22500, Mar 15, 2012.

  1. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    So i got a shotgun and after i fire a shell never ejects only way is load them individually even though it will hold more than one. What do i need to do?
     
  2. Hectocotylus

    Hectocotylus New Member

    292
    0
    0
    What kind of shotgun do you have? Info helps us help you :)
     

  3. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    I believe its a New England 12 gage i haven't taken it out for awhile cause i haven't had time. I also got it at Gander Mountain for 169
     
    Last edited: Mar 15, 2012
  4. robocop10mm

    robocop10mm Lifetime Supporting Member Lifetime Supporter

    11,380
    1
    0
    An NEF pump or single shot? We will need a bunch more info before we can crank up the crystal ball and divine an answer.
     
  5. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    Pump, it works great besides the no ejecting it doesnt latch on the shell at all is the main problem i think,
     
  6. kryptar19

    kryptar19 New Member

    1,774
    0
    0
    Sounds to me like an extractor problem. Check if its broken, and if so get it replaced.
     
  7. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    Yeah, i will check that out, if i load individual shells it ejects but if i load two or more than it wont latch, it feeds the shell fine just wont eject it.
     
  8. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    Here is the part that wont eject the shell

    ForumRunner_20120317_134341.jpg
     
  9. Rick1967

    Rick1967 Well-Known Member

    4,991
    48
    48
    maybe it is just the angle of the picture. But it doesn't look like it sticks out past the end of the bolt. I certainly should.
     
  10. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    It is just the angle it extends out and had a hook on it but it wont catch the shot shells
     
  11. Rick1967

    Rick1967 Well-Known Member

    4,991
    48
    48
    Does the ejector move freely? The detent should put some pressure on it.
     
  12. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    It all moves and works right it just doesnt catch the shell to pull it out
     
  13. Rick1967

    Rick1967 Well-Known Member

    4,991
    48
    48
    Is there any crub between the ejector and the channel that is rides in? Maybe it is not seating fully.
     
  14. Vinnie22500

    Vinnie22500 New Member

    23
    0
    0
    Nothing is there i might take it to gander where i got it from since they have the smith and all.
     
  15. tonydewar

    tonydewar New Member

    619
    0
    0
    duh fix it!or sell it to me for 20.00$
     
  16. PowerViolence

    PowerViolence New Member

    288
    0
    0
    wow did you find that thing in the ocean?
     
  17. chewchew

    chewchew New Member

    274
    0
    0
    clean and oil might help.