Saiga 12 FTF

Discussion in 'General Shotgun Discussion' started by Rustler07, Apr 19, 2013.

  1. Rustler07

    Rustler07 New Member

    4
    0
    0
    Hi Guys,

    I just got my Saiga 12 about 3 weeks ago so I am still learning how this gun works. I have already converted fire control group and replace the stock and all. Now I also know about how Saigas tend to not run weak rounds well so I also bought and auto plug by TAC 47. The first time I shot it with Winchester buck shot and it ran well. A few turns on auto plug and it ran smooth. So I took it out today and ran Federal slugs through it and I was having FTF issues. I put in the Winchester back in that ran fine the first time and it was doing the same. Now the FTF were not every time I could get 3 to 4 shots off and then it would not fire. The rounds looked like they seated fully and nothing but a click from the trigger. I removed the round and cycled the gun again and it would work like I said 3 to 4 more rounds and then FTF. Any hints you can give would be very much appreciated.
     
    Last edited: Apr 19, 2013
  2. kfox75

    kfox75 Well-Known Member Supporter

    7,307
    258
    83
    On your FTF rounds, was there a strike mark on the primer? When was the last time the shotgun was cleaned, and was the bolt cleaned, oiled, and wiped down after you test fire session? That is where I would start. Your firing pin could be gunked up, or your trigger assembly might be out of whack. I would start with a thorough cleaning first, then a test fire. Beyond that, no ideas. My entire amoukt of experience with Saigas is I have seen one at my LGS. Best of luck.
     

  3. 1911love

    1911love New Member

    1,488
    0
    0
    I'm no Saiga expert. My S12 runs buck and high brass like a champ. Wally World Federal family packs(#8 low brass) have nothing but problems in mine. It could be your gas ports weren't drilled properly at the factory and need to be opened up. I also have looked at Brownells(I think) Saiga 12 Ultimate Reliability kit.

    I'm going to convert mine soon so I'm not sure about this info yet. Hope this helps and good luck. I'll post after I get around to converting mine.
     
  4. MisterMcCool

    MisterMcCool Well-Known Member Supporter

    12,970
    396
    83
    FTF failure to feed? Are you saying after one round fires and ejects, it isn't chambering the next round?
     
    Last edited: Apr 21, 2013
  5. kfox75

    kfox75 Well-Known Member Supporter

    7,307
    258
    83
    McCool, The issue is a fail to fire, not a fail to feed. See above quote from the OP.
     
  6. Rustler07

    Rustler07 New Member

    4
    0
    0
    I broke the gun down and cleaned it. It did not have much dirt in it. Going to try it again Tuesday and hope that corrects the issue. I cant remember if the fail to fire rounds had a strike mark on them or not. If I have the problem again I will take note. Not sure what you mean by out of whack on the trigger group? While I was cleaning it I checked the trigger group out and everything moves nice a smooth. The pins are in place, they have a small amount of side movement but very little. Is that normal or should the be tight?
     
    Last edited: Apr 21, 2013
  7. Rustler07

    Rustler07 New Member

    4
    0
    0
    Well the test run on the gun after cleaning had bad things happen but also good things. Once again having fail to fire issues every so often. This time looking at the no fire shells there is no mark on the primer. I go through about 20 rounds then the damn BHO spring came off and the gun was done. So I take the gun apart to fix the BHO spring and notice that the main spring/hammer spring looks odd. The legs or arms whatever you want to call them no longer match. One is either bent to much or the other is not bent enough. Now this is and after market spring so I put back the original spring and put everything back together. The gun runs like a champ now without a single fail to fire in 100 rounds. Do any of you know what would cause the aftermarket spring to bend like it did? Not that it really matters the gun is running sweet and I dont think I am going to mess with it since its running good now.
     
  8. JonM

    JonM Moderator

    20,110
    19
    38
    not installed right. it can be a little tricky to get the internals back intot he recievers of the saiga 12 just right
     
  9. kfox75

    kfox75 Well-Known Member Supporter

    7,307
    258
    83
    This is what I meant by out of whack. Either an internal component or the trigger group is not seated right. Like I said in my earlier post, my total experiencewith a Saiga 12 is that I have seen one at my LGS.