S&W M&P Shield Issues...

Discussion in 'General Handgun Discussion' started by Stillersfan, Mar 24, 2013.

  1. Stillersfan

    Stillersfan New Member

    520
    0
    0
    I brought the Shield to the range over the weekend and discovered that I was having FTE issues. At first I thought my wife was limp wristing it, but when I tried it I got the same issue. I tired different magazines and still had the issues. Has anyone experienced this?
     

  2. Stillersfan

    Stillersfan New Member

    520
    0
    0
    Might be .. I was using WWB a few weeks ago with no issues. I was using Remington UPC 115grn FMJ. I wonder if the rounds aren't hot enough to extract??
     
  3. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Quite possible. Switch back to the other ammo and see if the issue is resolved. It's not uncommon for some guns to be finicky.
     
  4. BeyondTheBox

    BeyondTheBox New Member

    2,630
    0
    0
    Odd, not impossible, but odd. My friend's full size m&p eats wwb when we go out. That and Blazer and my Remington umc. But as Mountyman said, some guns are picky for some reason. Good luck, I'd be interested in knowing the result
     
  5. Steel_Talon

    Steel_Talon New Member

    1,766
    0
    0
    Was the pistol cleaned and oiled properly before shooting it?
     
  6. Stillersfan

    Stillersfan New Member

    520
    0
    0
    Yes Sir... Clean all my pistols with Ballistol after every trip to the range. I make sure all my guns are properly cleaned and oiled.