RRA Single stage trigger/ LPK question?

Discussion in 'AR-15 Discussion' started by DropZone889, Apr 19, 2013.

  1. DropZone889

    DropZone889 New Member

    86
    0
    0
    This is my first build and I got all my parts for lower complete W/ the Rock River single stage trigger LPK.
    When I cycle the trigger it releases fine and the hammer locks back too. But if I keep the trigger pulled back all the way and cycle the hammer back again while still pull on the trigger, it kinda gets stuck till push the hammer farther down, now if I don't keep pull on the trigger it works correct. Is there something wrong or is this the way it's suppose to work?? I saw a video on YouTube showing when you let off the trigger the hammer pops back up to fire position where as mine it sticks kinda or if push the hammer more down it resets. Do I have something wrong/ defective/ needs oil/ or??? (I hope someone can understand what I'm saying, i didn't use all the right vocabulary and describe in words right??!??)

    Any direction would help!
     
  2. highpowerguy

    highpowerguy New Member

    44
    0
    0
    Let's see if I am understanding this. Are you saying that when you hold the trigger back and push the hammer down it catches and holds but when you let go of the trigger it doesn't release it unless you push the hammer down a little?
     

  3. purehavoc

    purehavoc New Member

    4,799
    2
    0
    That is the disconnecters job . Nothing wrong with it
     
  4. highpowerguy

    highpowerguy New Member

    44
    0
    0
    The trigger should reset when you let go of it if it does not then it is not functioning properly.
     
  5. DropZone889

    DropZone889 New Member

    86
    0
    0
    Sorry for the long jumble of a post, but when I let of the trigger it doesn't reset unless I push down on the hammer again, then it resets. Is that a malfunction ?
     
  6. DropZone889

    DropZone889 New Member

    86
    0
    0
    Also if I just slightly touch the trigger in the forward direction, then the hammer pops up to reset and back ready to fire. I have a poly lower and I had to slightly dremel out two other areas like the mag release, I assume these are made in a mold and not machined like the alum ones so maybe I need to take the trigger out and recheck that area where the trigger comes through.
    Thanks again for all the help.
     
  7. purehavoc

    purehavoc New Member

    4,799
    2
    0
    Lube is your friend if u haven't used any. One more reason to stay away from poly lowers
     
  8. highpowerguy

    highpowerguy New Member

    44
    0
    0
    Use a little grease on the disconnector and sear (back of the hammer) surfaces. Then cycle it by hand a hundred or so times to wear the surfaces together. If this doesn't straighten it out then its possible the trigger spring isn't pushing up on the trigger hard enough. I have found these to be a little finicky on single stage triggers. You can tune them by taking the trigger out and bending the ears down a Little or by twisting the spring. If none of this works then consider buying another trigger spring.
     
  9. Quentin

    Quentin New Member

    7,551
    1
    0
    Ah, the rest of the story! Yeah, if the receiver had to be dremmeled then maybe there are other problems.
     
  10. DropZone889

    DropZone889 New Member

    86
    0
    0
    Thanks guys for the info and help! I kept cycling the fire control system and seems to get better and better but I may take it out just to make sure there isn't any clearance issues just to be safe.
     
  11. DropZone889

    DropZone889 New Member

    86
    0
    0
    FINAL UPDATE, I put a little grease and I kept cycling the FC over and over 100+ times and it works perfect!!!! I got a little worried about the lower being poly but it wasn't that, plus my friend has the same one and has run 500+ rounds no problems what so ever!

    But thanks agin Brothers in Arms for the guidance!!!!!!! :)