rings won't tighten to base?

Discussion in '.22 Rifle/Rimfire Discussion' started by old fart, Sep 26, 2012.

  1. old fart

    old fart Member

    344
    1
    18
    i have a savage mark 2, it uses the two piece weaver bases. i bought a set of quad lock rings for it, but with the rings tight i can move them front to back on the bases. what can be the problem?, thanks for any help.
     
  2. old fart

    old fart Member

    344
    1
    18
    found my problem, the bases on the gun was #24 weaver. the savage takes #16 weaver, now i don't know what kind of rings fit the #24 but when i went and got #16 bases my ring tighten down good. they look just alike but there is a difference. thanks
     

  3. big shrek

    big shrek Well-Known Member

    1,832
    44
    48
    sounds like the difference between metric & standard kind of thang...

    IIRC, there are two styles available, one metric & one standard...Weaver website should show the diff...
     
  4. MarkAD

    MarkAD New Member

    53
    0
    0
    Sounds like it was a difference in the bases. Of course now you have to buy rings that fit the #24 bases and you can't have rings and bases without a gun to put them on.
    Reckon y'all got to buy a new guy now.
     
  5. old fart

    old fart Member

    344
    1
    18
    the 24's fit the savage mark 2 but i have tried 3 different set of rings and they are all loose. savage recommended the 16's and the rings fit them good, so i don't know whats up with the 24's. even though they fit the savage they are not listed as to fit, does anyone know what the #24 weaver bases are supposed to fit? thanks