Ria fte

Discussion in '1911 Forum' started by kytowboater, Nov 23, 2012.

  1. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    SOoooooooo, I was at the range today. Shy through my carry ammo (185 grain Hornady Critical Defense) then 100 rounds of Tula 230 ball.

    Even with the Hornady, I was getting a Failure to eject about every 3rd shot. Even with a good firm grip. I even tried limp writing intentionally. Same thing though, some shots with a weak grip it operates fine... ?????

    First time this has happened too. Any ideas? Extractor? Recoil spring to stout? It's frustrating.
     
  2. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    It would also do it 5 or 6 times in. Row.
     

  3. SSGN_Doc

    SSGN_Doc Well-Known Member

    6,921
    42
    48
    You said "first time this has happened". So, did you put anything different in or on the gun? Try different lube, mags, ammo, etc. Have you tried the same loads in it before with no problems?

    Was it failing to fully extract? Failing to pull the case out at all? Failing to eject an extracted round?

    Just trying to narrow down the variables.
     
  4. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    Nothing new. It failed to completely extract the empty casing. Not chambers new round and forcing the slide back, not far enough to lock the slide back. The case would be halfway in the chamber or seated all the way in the barrel. Grip did not affect the way it shot.

    Hoppes solvent G96 clp, Wilson mags. It choked on Hornady ammo and Tula both.
     
  5. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    Won't fully eject a spent case a chamber a live round.
     
  6. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    I guess I will buy a new recoil spring in a lighter weight tomorrow. Hope that fixes it.
     
  7. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    Also, the slide has not been locking back on the last shot.
     
  8. SSGN_Doc

    SSGN_Doc Well-Known Member

    6,921
    42
    48
    If the slide is failing to travel all the way to the rear, then yes, it could be the recoil spring, but if the gun worked 100 percent with this ammo before I would doubt that the spring is the culprit because they usually don't get stronger with use. Maybe the rails and barrel hood were not lubed well.

    Most other issues would have to do with extractor tension.
     
  9. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    Okay. Maybe I can put some grease on the slide rails, I will look up a way to check the extractor.
     
  10. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    Ill break it down and check for significant rub in areas. Just strange as its not done this before. I've had maybe 3 or 4 like this happen in 1000 rounds. Now boom! Lol damn near every round. If I can't figure it out I can drop it off at the gunsmith.
     
  11. SSGN_Doc

    SSGN_Doc Well-Known Member

    6,921
    42
    48
    Or talk to the folks at RIA. I have only read good things a out them making things right for owners if they have a problem with one of their pistols.
     
  12. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    Ah, seems I have overlooked that fact. Lol. Thanks. Ill give them a shout tomorrow. Thanks.
     
  13. utf59

    utf59 New Member

    676
    0
    0
    Is it failing to lock back on more than one magazine?
     
  14. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    Yep. Anything. I don't know if somehow I dinged the extractor outta tune?? Idk. Blah. I sent Ivan at Arnscor an email. So we shall see. It will pull the spent brass halfway out of the barrel then try to strip a fresh round jamming the slide. I have to lock the slide back, drop the mag and shake the empty out or rework the slide to extract the empty. Then load and start over.
     
  15. utf59

    utf59 New Member

    676
    0
    0
    Let us know how it works out.
     
  16. nightal

    nightal New Member

    54
    0
    0
  17. kytowboater

    kytowboater Active Member

    7,180
    4
    38
    I just checked the tension and its fine. Ill call Shawn again tomorrow. He told me to check the tension today. Ill send it off to RIA tomorrow and go from there. Thanks again guys.