Pmag M3 and M4? Having problems...

Discussion in 'AR-15 Discussion' started by jack80, Dec 28, 2012.

  1. jack80

    jack80 New Member

    100
    0
    0
    Hey guys, sorry for so many questions. I have a Ruger SR556. It came with 3 pmags with M4 stamped on the side. I bought 10 extra but they have M3 on the side. When I fire the last round from the ones labeled M3 the bolt doesn't catch. If I pull the charging handle back with an empty mag the bolt catches until I release the magazine then it closes. It works normally with the one labeled M4. I've fired less than 100 rounds through the gun it's brand new. Just looking at the mags I can't see a difference.
     
  2. jack80

    jack80 New Member

    100
    0
    0
    Oh, haha, so the question is... Any chance I can modify the mag or do you think maybe when the guns actually broke it it'll work magically?
     

  3. Jpyle

    Jpyle New Member

    4,828
    0
    0
    Could be the mags...all the mags are technically P Mag M4s...the M3 is the 3rd generation. There may be spring differences between the 2nd and 3rd gen mags. How hot is the SR556 running recoil-wise. If it is cycling too fast the M3 follower may not be in place quick enough or the bolt is just overpowering the catch mechanism. Try running with a tad less gas and see if the problem goes away...just a thought.

    And no I wouldn't mod the mags...even if they won't work they are probably worth about $100 each on e-bay by now. :cool:
     
    Last edited: Dec 28, 2012
  4. jack80

    jack80 New Member

    100
    0
    0
    I'm 99.9% sure they're not the new gen pmags. I actually just looked and some have M8 on them. I'm including a pic, the numbers right above my finger, you can barely see it.

    image-1686658137.jpg

    Also, they are all MAG211-BLK The packaging is the same except I noticed one different number on the bags. The A01 number on bottom left


    image-794015539.jpg
     
  5. purehavoc

    purehavoc New Member

    4,799
    2
    0
    That A01 number the lot number mag211-blk shows its a gen 2 mag ,note mag2 , what ammo are you shooting ? maybe low gas situation and you may need to turn it up a bit
     
  6. jack80

    jack80 New Member

    100
    0
    0
    I don't even have to shoot it to see the problem. I have changed the settings from 2 to 3 though. Was just shooting some cheap TulAmmo 55gr. Thanks for the info about the lot number, I opened 2 more mags and lot number didn't matter. It just doesn't like the ones with the M3 stamp on it.
    If I put in an empty "M3" mag and pull back the charging handle it doesn't engage the bolt catch . See pic

    image-1131850278.jpg

    But if I use the one labeled "M4" it does

    image-938403695.jpg
     

    Attached Files: