New Stoeger Cougar Reassembly Help

Discussion in 'Auto & Semi-Auto Discussion' started by camcardshark, Aug 20, 2010.

  1. camcardshark

    camcardshark New Member

    2
    0
    0
    I just got a brand new Cougar, Sliver 9mm. When I got it home I took it apart(what i assume everyone does) and was putting it back together. When I got it all back together, it worked fine however, I noticed the metal guide rod sticks out the front of the gun just as much as the barrel.

    Is this normal, or am I messing something up? The manuel shows the guide rod and spring fully through the center block. On mine, there is a little lip on the side of the center block that the back of the guide rod goes through that won't let the guide rod go through the center block.

    Again not sure if this is right but when i rack the slide it seems to function normally, the only noticable difference is the guide rod sticking out of the front of the gun.

    Any and all help is appreciated!!!
    Thanks
     
  2. dunerunner

    dunerunner New Member

    8,411
    3
    0
    Welcome, I'm not familiar with that weapon but maybe someone will stop by with an answer.

    Oh, look what I found! Is this your gun?

    [ame=http://www.youtube.com/watch?v=SsPSQdzv8eU]YouTube - Stoeger Cougar Review Part 2[/ame]
     

  3. canebrake

    canebrake New Member

    21,833
    3
    0
    Here's what a friend told me;

    I have found that the best way to re assemble is to hold the slide upside down in your left hand. Place the barrel and the block/spring assembly over it in the correct manner (it only fits one way). Then keeping it all upside down, carefully slide the frame into the rails, again upside down. Invert and flip the locking lever and voila!!! just pull the slide a few times to make sure that it all fits/works and you 're done!!!
     
  4. camcardshark

    camcardshark New Member

    2
    0
    0
    I guess I need to rephrase my question... My main concern is that my center block, unlike the one in that video, has a lip on it were the back part of the spring/guide rod(so the part that faces the rear of the gun) is unable to move past a certaint point. My question is am i supposed to only push it to the lip or should i be able to get it past the lip?

    Again, Thanks for the replies!
     
  5. chad2

    chad2 New Member

    41
    0
    0
    that lip is not supposed to be there and yes that gide rode is supposed to go all the way through the block try and shave it down or something maybe just a defect
     
  6. danf_fl

    danf_fl Retired Supporter

    12,369
    57
    48
    Before shaving or doing anything, do you have pics you can post?
    Show the underside of the slide with barrel and guide rod in place.
    Close ups of the guide rod will really help.

    camcardschark and chad2, welcome to the FTF, please stop by the "introductions" section and tell us about yourselves.