Need help with my Savage Model 25 lightweight varmint chambered in .223

Discussion in 'General Rifle Discussion' started by wildfan1833, Jan 8, 2012.

  1. wildfan1833

    wildfan1833 New Member

    10
    0
    0
    I just took my new Savage Model 25 lightweight varmint .223 out to the rang for the second time. And again it will fire some times and other times it wont. I took the bold out and ran parts cleaner to clean out the grease that was in were the spring is. I thought that would fix it and nope. I tried hand loads and factory loads and some times it would fire and some times it would just barley hit the primer and not go off. Should I send it back in?


    Also I can't get my scope to zero in and it's bottomed out for up and down and it's never done that on the 308 and the 223 it was on before. I bought lower scope rings and it shot higher than it did with the higher rings on it. Any thoughts? The bullets were hand loads and were the same and fired before
     
  2. hiwall

    hiwall Well-Known Member

    4,269
    22
    48
    The firing problem is most likely crap inside the bolt body(dis-assemble and clean bolt) or the bolt is not fully closed when you try to fire.
     

  3. wildfan1833

    wildfan1833 New Member

    10
    0
    0
    I have never done anything like this how should I go about doing this? Thanks for the help so far. This is the first new gun I have owned so I don't know what can be expected and if problems occur how to fix them
     
  4. JonM

    JonM Moderator

    20,110
    13
    38
    A common issue with savage bolts is too shallow firing pin protrusion combined with a slightly weak or gummed up mainspring.

    If you do a search on savage model 10 bolt disassembly you should find an in depth write up i did on taking one apart and putting it back togethor.

    If your still getting light strikes after cleaning extend the firing pin out one notch of rotation and try again.

    Cant pull the link as im on my nook atm and it doesnt cut and paste
     
  5. wildfan1833

    wildfan1833 New Member

    10
    0
    0
    Thanks for the help everyone. I took the gun back to where I bought it and they gave me a new one and said if I have the same problems bring it back. So we will see what this weekend brings