Mosin nagant 91-30 fail to eject

Discussion in 'Curio & Relic Discussion' started by relichound, Jul 16, 2014.

  1. relichound

    relichound New Member

    58
    0
    0
    Ok I finally got around to de cosmolining my mosin, pulled all the parts Down soaked the metal in simple green water solution and oiled and reassembled , now it won't eject rounds . I did pull the interrupter and ejector to de gunk them good , did I mess up and not put it back togher right?
     
  2. dteed4094

    dteed4094 New Member

    799
    2
    0
    Did it eject before the clean-up?
     

  3. 303tom

    303tom Well-Known Member

    5,217
    173
    63
  4. JonM

    JonM Moderator

    20,110
    19
    38
    might have a worn or broken ejector. see the link from 303Tom
     
  5. relichound

    relichound New Member

    58
    0
    0
    Was fine before

    Before the. Cleaning it ejected like a champ now the round stays on the bolt all the way back
     
  6. JonM

    JonM Moderator

    20,110
    19
    38
    Sounds like the ejector broke or fell out when cleaning. A really good close up with bolt removed of the left inside side of the receiver would help
     
  7. Mercator

    Mercator Active Member

    11,342
    16
    38
    Rule out the interrupter first. If it is worn or ever so slightly bent or out of place after the reassembly.
     
  8. relichound

    relichound New Member

    58
    0
    0
    Will do next time I'm back home I work away from home 10days at a time and my mosin is not with me ,