M1 Garand clip ejection

Discussion in 'Gunsmithing Forum' started by bobalo59, Apr 3, 2012.

  1. bobalo59

    bobalo59 New Member

    20
    0
    0
    I have a 1944 M1 Garand, I"m having problems with the clip prematurely ejection out of the reciever before all rounds have been shot. This is a reletively new problem. The gun has worked wonderfully for me and I take it to Camp Perry every August. Really need some help here guys.

    Could it be the ammo I'm shooting? The ejector mechanism itself. Please point me in the right direction.
     
  2. JonM

    JonM Moderator

    20,110
    19
    38
    I dont have a schematic for the correct part name, but it is liekly a worn part. I can look it up later this evening if no one gets it by then.
     

  3. mountainman13

    mountainman13 New Member

    11,488
    0
    0
  4. JonM

    JonM Moderator

    20,110
    19
    38
  5. bobalo59

    bobalo59 New Member

    20
    0
    0
    Awesome guys, keep the info coming. I think I'll go ahead and order the clip latch spring and pin, it never hurts to have back up parts.
     
  6. c3shooter

    c3shooter Administrator Staff Member

    21,452
    587
    113
    First, make sure that the clip latch and spring are clean and lightly lubed. If they are, would bet on the spring being worn.

    Of course, for problems of premature ejection, we usually need to send you to a specialist. :p
     
  7. JWagner

    JWagner New Member

    598
    0
    0
  8. Tackleberry1

    Tackleberry1 New Member

    6,165
    3
    0
    HeHeHe

    You beat me to I C3! Has anyone suggested Cialis? Some of the older guys here swear by it!

    Tack