M&P 40 troubleshooting

Discussion in 'M&P Forum' started by BrandonB, Nov 3, 2012.

  1. BrandonB

    BrandonB New Member

    9
    0
    0
    I just got a M&P 40 and can not get it to fire. The firing pin spring seems weak does anyone know what might be going on.
     
  2. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    New or used? It's probably a safety issue.
     

  3. BrandonB

    BrandonB New Member

    9
    0
    0
    It is slightly used
     
  4. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Are you getting light primer strikes or no strikes ?
     
  5. BrandonB

    BrandonB New Member

    9
    0
    0
  6. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Have you taken the gun apart? Did you get if from an ffl?
     
  7. BrandonB

    BrandonB New Member

    9
    0
    0
    Yes and it came from a gun show
     
  8. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Eek. Ok did you take the slide apart?
     
  9. BrandonB

    BrandonB New Member

    9
    0
    0
    I just tried it again and it is leaving a small indignation in the primer
     
  10. BrandonB

    BrandonB New Member

    9
    0
    0
    I didn't take it apart I just took the slide off the action to see if it had any ware
     
  11. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Probably needs a spring kit then.
     
  12. BrandonB

    BrandonB New Member

    9
    0
    0
    Earlier it wasn't striking when I took the slide off I worked the firing pin by hand at first it was very tight it has loosened up some and now it leaving a dent in the primer. So I would guess a firing pin spring kit
     
  13. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    With that added context I'd say it might just need a good cleaning. You should be able to find a video on YouTube that explains how to take the slide apart.
     
  14. canebrake

    canebrake New Member

    21,833
    3
    0
    Squirt some CLP in the striker channel and dryfire the snot out of it.

    Bet it goes boom shortly after.

    If it does, completely strip the gun, clean it thoroughly and enjoy your "slightly used" [sic] M&P.

    (canebrake would go back and kick the seller's azz!)
     
  15. BrandonB

    BrandonB New Member

    9
    0
    0
    Thanks for the input
     
  16. BrandonB

    BrandonB New Member

    9
    0
    0
    Just wanted to let everyone know I found the problem on the gun the spring in front of the firing pin was bent and blocking the firing pin from following all the way through I fixed the spring and now its shooting fine .
     
  17. kodiak

    kodiak Member

    99
    0
    6
    Now get that lube out of the striker channel it doesn't belong there.
     
  18. jakebrake

    jakebrake New Member

    664
    0
    0
    yeah, why do gun show purchases never seem to work out well?