I. O. inc AK problem.

Discussion in 'AK & SKS Discussion' started by bigbomar4, Dec 9, 2012.

  1. bigbomar4

    bigbomar4 New Member

    453
    0
    0
    This weekend I took my new I. O. Inc Polish Sporter out for the first time. It shoots dead on but it will not feed under its own power. If I manually work the action it will feed and extract just fine. After I shoot either the bolt will recoil and then close back on an empty chamber or it will stop right before it would strip a new round. When it does this the old empty case is usually just sitting in the action and you have to shake it out. Ive used the two poly mags that came with the gun along with one steel mag and they all had the same problem. Also I am using cheepo Tulammo dont know if that would cause this problem tho. Thanks for any help.
     
  2. Sniper03

    Sniper03 Supporting Member Supporter

    7,715
    197
    63
    4,

    I think you have an ammunition problem from the sound of it. Get a box if "good" ammo from Walmart (Remington/Winchester etc) or other source and try it. It seems not to be the magazines due to the fact you have tried three of them. If there is no drag when you pull it back by hand and let it go loading a round. Probably weal ammunition that is failing to cycle the weapon. If that doesn't work and the rifle is new send it back.

    03
     

  3. SSGN_Doc

    SSGN_Doc Well-Known Member

    6,927
    66
    48
    An AK should run on any of the cheap steel cased ammo since it is what they were made to run on. Have you shot it without problems before? Does it have a recoil buffer on the recoil spring that may be causing the bolt carrier to bounce forward before ejection and the mag spring have time to work? How does the ejector look? What type of plastic mags came with it? What type if steel mag did you try?
     
  4. bigbomar4

    bigbomar4 New Member

    453
    0
    0
    This was my first time shooting this gun. I never got off two consecutive shots without having to manually work the bolt. There is no recoil buffer. The two plastic mags are I.O. mags. I can't find any markings on the steel mag. The guy at the gun store just pulled it out of a box of old mil surp mags. With the holidays coming up It may be a month before I can get out to the farm to shoot again.
     
  5. SSGN_Doc

    SSGN_Doc Well-Known Member

    6,927
    66
    48
    Can you take off the action cover and take a picture inside so that we can see the ejector and action rails. Also the bolt face may be useful to have a pic of along with the recoil spring.

    Otherwise the gas block/gas port, magazine height, could play into it.
     
  6. GaryGlock

    GaryGlock New Member

    684
    3
    0
    Sounds like your gas port or block is clogged, have you fieldstriped it to see If its full if cosmo?
    Your ammo has nothing to do with it, if its functioning properly it will eat any ammo you throw at it.
     
  7. GaryGlock

    GaryGlock New Member

    684
    3
    0
    Do this if you can please
     
  8. bigbomar4

    bigbomar4 New Member

    453
    0
    0
    Maybe this will work. This the first time Iv ever attached pics.
     

    Attached Files:

    Last edited: Dec 9, 2012
  9. SSGN_Doc

    SSGN_Doc Well-Known Member

    6,927
    66
    48
    Pics look pretty good. Nothing too obvious there. Could use one more shot from above the action without the bolt carrier in place to be able to see the ejector and the area right before the rear of the barrel.

    Can you get a small piece of wire or a pipe cleaner to go through the gas port and into the barrel where you can see it? Sometimes there can be some metal fouling from drilling the gas port that get into the port.
     
    Last edited: Dec 9, 2012
  10. bigbomar4

    bigbomar4 New Member

    453
    0
    0
    I cant get a wire in the gas port but the wire I have is pretty stiff. I will try and find something softer at work. I did shine a bright light down the port and I cannot see anything down the barrel.
     

    Attached Files:

  11. SSGN_Doc

    SSGN_Doc Well-Known Member

    6,927
    66
    48
    The ejector looks a little rough on the edge, and I'm used to seeing more of a hook shape on the leading edge.

    [​IMG]

    [​IMG]
     
  12. GaryGlock

    GaryGlock New Member

    684
    3
    0
    Try some Very light de-buring on the ejector, and that piston looked a little dirty but nothing that should be causing malfunctions. Try to clean that up a little.
    I feel like your not getting enough air to cycle properly
     
  13. bigbomar4

    bigbomar4 New Member

    453
    0
    0
    What would be best to debur it with? A fine file or emory cloth? I have no experience with anykind of gun smithing. Also the piston is clean. That is pitting in the metal. There is also a tiny bit on the sides of the piston but it doesnt go all the way through any of the rings. I forgot to get any softer wire at work today to see if the gas port was clear but should I be able to see some light shine through it into the barrel?
     
  14. GaryGlock

    GaryGlock New Member

    684
    3
    0
    I would start with a very fine sand paper, and when I say just touch it to it I mean like 2-3 quick brushes and then some emry. And yes if you shine light in the gas port u should see something in the barrel.
     
    Last edited: Dec 11, 2012
  15. PanBaccha

    PanBaccha New Member

    3,054
    0
    0
    Hmmmm, very interesting!
     
  16. nfafan

    nfafan Member

    277
    3
    18
    I'm with the "check the gas port crowd" - maybe not enough oomph to properly cycle? Clean that port.

    And try a different mag just to be sure - I have a 40rd Romy mag that will only work perfectly in one of 4 AKs.

    Be sure you contact IO immediately - they may frown on you doing WECSOG work on the guts when they should be working over your AK under warranty.
     
  17. Werminator

    Werminator Member

    668
    4
    18
    Im with NFAFAN... Send it in to them. You might have to pay a bit of cash to ship it but better than having to buy replacement parts if something gets ruined or by playing the guess and check repair protocol...