Glock 30sf Not Chambering

Discussion in 'Glock Forum' started by ki7be, Nov 16, 2009.

  1. ki7be

    ki7be New Member

    I have a new 30sf. So far I have only put about 100 rounds through it. I have noticed that after about the 3rd or 4th round doesn't chamber, and hangs in the ejection port. After I take out the round the gun fires the remaining rounds OK. I am using Federal AE45A2 230g FMJ. I haven't tried any other brands yet. Could this be a problem with the gun or ammo. I told this story to a authorized glock dealer, and his advice was to send the pistol back to glock. He also told me that there have been problems with the 30sf, and that he felt sorry I bought a glock. Any advice would be appreciated.

  2. Dillinger

    Dillinger New Member

    Well, Welcome to the FTF Community.

    Might suggest you stop by the introduction section and let the guys know who and what you are about.

    With one time of ammo, and presumably only one magazine tried, that is not easy to diagnose over the Interwebz.

    First, I would check the feed ramp with a cotton ball. Does it snag or hang when you rub the cotton ball across the feed ramp?

    Second, I would recommend trying some different ammo and perhaps an additional magazine or three to see if the problem persists...

    I wouldn't accept that from a brand new pistol though. If you can't get it to work, ship it back and get something else.


  3. User Name

    User Name New Member

    That sucks you are having problems! I would second Dillinger in saying try another mag with diffrent ammo. Glock will fix it though. They are a great company that makes very good firearms. Glocks are known to be one of the most reliable handguns on the market. If the one you got is having problems, then Glock will make it right. Good luck to you.
  4. canebrake

    canebrake New Member

    First, go over to the Introductions section and let us know a little about you.

    Until then I'll hold off on any glock jokes.