Firearms Talk banner

1 - 11 of 11 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Hello, I've been shooting glocks for about 6 years now. I've owned the 27 and the 21. I now own the gen 4 17 and 26.

My 26 has around 500 rounds down the pipe. It has given me no problems until yesterday. We were shooting wwb ammo with the factory 10 round mag. Near the end of the session the slide started locking back halfway through the mag. It did this to me and my friends. It kept doing this and towards the end it was locking back every other round.

I know that an improper grip can cause this but since I've never had this problem before I think it's mechanical. Does anyone know what could be causing this? Thanks for any help.
 

·
Registered
Joined
·
99 Posts
Alright let me rephrase, did you and your buddy detail strip your Glock at anytime? Check to see if your slide stop lever spring is under the locking block pin (top pin).
 

·
Registered
Joined
·
64 Posts
Discussion Starter #5
I have detail stripped my glock once. It ran fine afterwards. That was about 200 rounds ago. Although, I will check that out when I get home from work.
 

·
Registered
Joined
·
99 Posts
GLKmiester said:
I took the slide off and this is what I saw. Do you think the spring will be salvageable?
Don't know, take it out and reinstall it properly. In the interim just go ahead and order a new SSL. Chalk it up to a lesson learned, bet you don't do that again ;)
 

·
Registered
Joined
·
64 Posts
Discussion Starter #10
kodiak said:
Don't know, take it out and reinstall it properly. In the interim just go ahead and order a new SSL. Chalk it up to a lesson learned, bet you don't do that again ;)
Thanks. I did reinstall it after reviewing some detail strip videos. I'm not sure what I did wrong though. I would like to know so I don't have to worry about it ever happening again.
 
1 - 11 of 11 Posts
Top