Front Factory Tijicon Site Out Again!

Discussion in 'XD Forum' started by LikeABoss, May 16, 2012.

  1. LikeABoss

    LikeABoss Member Lifetime Supporter

    818
    0
    16
    Just got my slide back from SA for my XDm .40 S&W, they replaced the front Trijicon that stopped glowing. Burned 200 rounds through it. Guess what, site went out again! WTF? I am guessing it has something to do with dropping my gun in my bag when it is still hot, could this be the reason? Crazy. :confused:
     
  2. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Idk man. I've never had a problem with them aside from having to do a bit of fitting for the glocks rear sight.
     

  3. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Maybe its a heating/cooling issue that's causing the "glass" to crack?
     
  4. LikeABoss

    LikeABoss Member Lifetime Supporter

    818
    0
    16
    Your heating cooling principle sounds plausible, guess i will send back to SA again, ask them to put a factory dot sight on it and give up on the Trijicon.
     
  5. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    Did they explain the problem with the last one?
     
  6. LikeABoss

    LikeABoss Member Lifetime Supporter

    818
    0
    16
    no, they just replaced it
     
  7. mountainman13

    mountainman13 New Member

    11,488
    0
    0
    I wonder if they are feeding you old stock of course they would have to have been sitting on it for like 12 years. Unlikely unless the same sights work on an older model.
     
  8. LikeABoss

    LikeABoss Member Lifetime Supporter

    818
    0
    16
    I am done the the Trijicons, asked them to replace with premium white dot sights which they said they would do.