Embarrasment

Discussion in 'The Club House' started by anm2_man, Mar 15, 2009.

  1. anm2_man

    anm2_man Member

    504
    2
    18
    Has anybody made a post and then found out a simple dumb fix fixes the problem ? Well I just did one. I will not name where I posted it, but after looking again, I found some dirt in a tube that is to except a primer. I complained about the new product I was using and wanted an answer. Well just get rid of the dirt and everything works just fine.

    :D
     
  2. Benning Boy

    Benning Boy New Member

    9,624
    1
    0
    To anyone familiar with the SKS, I cleaned mine and forgot to switch the gas tube back to the rifle mode from grenade mode.

    So I'm at the range, thing won't cycle, I'm getting really pi$$ed, cause I spent days getting the cosmo out of this thing, to the point if anyone else was there, I would have traded it for a pack of smokes on the spot.

    After cursing loud enough to wake the gods, my eyes catch the switch, and the embarassment begins.

    Of course, I didn't post on it, though.:D;)
     

  3. hunter Joe

    hunter Joe New Member

    2,361
    1
    0
    I starting shooting the Ruger Mark II again, so I thought I'd clean it. I spent a hour trying to get that dang thing back together. I finally dug out the owners manual after much frustration. It's that "I don't need no stinken instructions" attitude that gets me every time.
     
  4. Bill of Ojai

    Bill of Ojai New Member

    35
    0
    0
    As the assistant armorer in military high school, I didn't reassemble my M-1 Garand correctly. Next day we had an Inspector General visit and all the Garand guts flew out in the face of General Curtis LeMay at inspection arms.

    My military career ended.
     
  5. roosterjuicer

    roosterjuicer New Member

    303
    1
    0
    my vacuum was having some suction issues. i cleaned out the filter element. took apart the motor and checked every single belt. after a couple hours of trouble shooting with my roommates i finally thought I would check the suction tube. there ended up being a sock stuck in it, not letting any air through.

    lesson learned, start at the simplest possible solution and then work your way to more complicated things.
     
  6. skullcrusher

    skullcrusher New Member

    10,888
    1
    0
    Took the .40 cal carbine out yesterday. 3 of us out, and was to be first time shooting ever for 1. We did pistols for a good while, and then we pulled out the rifles. He was eager to try out his inherited Rem 600 in .35, and so were the rest of us (some guys just get lucky). :D

    Anyhoo, long to short, I started shooting the carbine. F'n thing stops cycling for the first time ever. :mad: Bolt issues. I looked it over a couple of times, cycled it, checked the mag, etc. It would only go 1 and done. I put it away.

    We got back in and I decided to go lubing, cleaning and inspecting. I realized that I had not tightened the bolt stud and the bolt cover thingy was getting wedged into the slot. :mad:

    This afternoon, I took it out on my home range, and it cycled 2 mags with ease. It sucks for my friend, because he may not get another chance in the near future.

    I did get to run 8 rounds thru the Rem 600, though. :D

    Everytime you experience something new, you learn something you will never forget.
     
    Last edited: Mar 16, 2009
  7. Old Sarge

    Old Sarge New Member

    8
    0
    0
    Hey, we've all made mistakes, and said something that we wished we hadn't said, but it's all a part of the learning process. Live and learn. ;)
     
  8. skullcrusher

    skullcrusher New Member

    10,888
    1
    0
    Good wisdom from Old Sarge. Welcome to the forum. :D
     
  9. canebrake

    canebrake New Member

    21,833
    2
    0
    WELCOME Old Sarge, unfortunately life doesn't come with a rewind button. Let's hope we won't need one very often! [​IMG]
     
  10. c3shooter

    c3shooter Administrator Staff Member

    21,335
    193
    63
    One morning, in the office early, about an hour before starting time- pile of crap to get done. My office was back near the coffee locker. Was up to armpits in drawings, when our new VP stuck his head in office, asked howzit going? Distractedly replied "Busier than a one armed paperhanger." 30 seconds later, realized what I had said- and to who. Walked into coffee locker, apologized to boss- who had lost right arm to a claymore in RVN. :eek:

    Frankly, I was more embarassed than he was bothered by it.
     
  11. dragunovsks

    dragunovsks New Member

    2,310
    0
    0
    About 4 months ago I bought a used truck. An 01' Dodge Dakota with 3.9L V-6 and a 5-speed manual tranny. Bout a week after I bought it the check engine light came on, didn't think much about it at first because I had a 97' Dakota 3 years ago and the CE light was on for the last 2 years I had it.

    Anyways, I took it to a local auto repair shop and then to another just to get a second opinion about possible repairs. The second shop told me when I put gas in it to make sure the gas cap clicks when I'm done fueling up. Apparently this causes a minor vaccum leak and sets off the CE light. I felt like a duffous.

    In my defense, my 88' F-150 that I was used to driving doesn't care about little things like that.:eek:
     
  12. Benning Boy

    Benning Boy New Member

    9,624
    1
    0
    OMG, did the same thing. Had the car 3 days, put gas in it, and on comes the CE.

    I'm 10 minutes from the dealer, right back into the lot. I want it looked at now. Can't do it for a week. B.S., get me your manager. The manager's a little blonde twig, and suggests the gas cap. I get really condescending, she sets an appointment for the next day.

    I'm leaving, look at the gas cap, and give it a little twist, start the car, light goes out.

    I drove off slumped as far as I could into the seat.
     
  13. dragunovsks

    dragunovsks New Member

    2,310
    0
    0
    That's funny Benning. Mine didn't come on till 3 or 4 days after I put gas in it, which was weird. Once I corrected the problem it took 2 days to go off, but it hasn't come on since.:confused: