Benelli SBE II not so easy on the eye.

Discussion in 'General Shotgun Discussion' started by E-Rez, Oct 17, 2011.

  1. E-Rez

    E-Rez New Member

    35
    0
    0
    When using waterfowl loads, my SBE has a bad habit of shooting fine debris into my right eye (aiming eye) during the shot. This will happen one to two times during a hunt. It only does it with waterfowl loads...never with light clay loads. I'm sure it would do it with turkey loads too, but I don't shoot enough of those to know.

    Anyone else experience this? I love the gun, but it might have to go if there's no cure for this.
     
  2. E-Rez

    E-Rez New Member

    35
    0
    0
    With 46 views and no responses, should I assume nobody else has experienced this?
     

  3. JonM

    JonM Moderator

    20,110
    19
    38
    Is your gun ported??

    porting can cause this to occur. Only cures are get a unported barrel, switch ammo brands different powders act different on ported guns, or wear shooting glasses which you should be doing anyway ;)

    One other thing be sure the barrel nut is tightened its outside possible its a little loose and gunk is leaking back past the reciever. Look for fouling on the outside of the reciever where the barrel and reciever come together. If its tight and there is fouling you MIGHT have a out of round barrel or reciever. That would be a condition benelli would have to rectify
     
    Last edited: Oct 19, 2011
  4. E-Rez

    E-Rez New Member

    35
    0
    0
    No porting. Don't see fouling either. I wear safety glasses shooting in the yard or range, but not in the field. I feel that I shouldn't need protection every time I pull the trigger on a $1300 gun. Unacceptable IMO. I've duck hunted with a Rem 870, Mossberg 835, Benelli M1 Super 90, and Benelli Nova...Never had this happen with any of those guns. The inside of the reciever was cleaned prior to the last hunt. This is how dirty it got after a half dozen shots. Never used to get that dirty even after 100 rds of bulk Federals. But, like I said earlier, I only get crap in my eye with waterfowl loads. The loads I've used have been Kent, Federal Black Cloud, and a cheaper Federal steel load (can't think of what it's called).
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  5. JonM

    JonM Moderator

    20,110
    19
    38
    that looks like its over lubed. how much oil are you using??

    another cause could be overly leaded up bore. i use one of these: Tornado Style Bore Brush 12 Ga 5/16 x 27 Thread SS

    it does a relly good job and its pretty amazing the amount of lead that comes out.

    just some more things to look at