AR-15 problem trigger

Discussion in 'AR-15 Discussion' started by SeanTLog, Mar 1, 2010.

  1. SeanTLog

    SeanTLog New Member

    13
    0
    0
    i just put in a new rock river 2 stage trigger and ive got about 200 rounds through with it but its been hanging and i have no clue how to fix it any info and help would be great
     
  2. jmac2387

    jmac2387 New Member

    29
    0
    0
    Trigger Job

    What does hanging up mean to you.

    What are you observing and what is the trigger doing or not doing?

    JM
     

  3. DrumJunkie

    DrumJunkie New Member

    4,823
    0
    0
  4. stalkingbear

    stalkingbear Active Member

    4,078
    6
    38
    Are you SURE you have the spring in right?
     
  5. SeanTLog

    SeanTLog New Member

    13
    0
    0
    when i got to pull the trigger back after a shot it feels like its catching on something and when i pull it a few times ill will give im clueless as to what i might need to do i dont think its in wrong because it will run flawless for a few rounds sometimes
     
  6. deth502

    deth502 New Member

    137
    0
    0
    first thing id do would be to disassemble and clean it.

    first, the "dragging on something" intermittently tell me that theres a good chance its just some dirt in there, and if not, the disassembly will also reassure you that youve put everything in correctly.
     
  7. SeanTLog

    SeanTLog New Member

    13
    0
    0
    well see the thing is it did it the 1st time i put it in. i took it out greased it real well put it back in and you would go to pull the trigger and it wouldnt. pull it a few times and for no reason nothing different it would release and that was before it had its cherry popped. Could it have anyhting to do with the ambi saftey selector i installed?
     
    Last edited: Mar 1, 2010
  8. deth502

    deth502 New Member

    137
    0
    0
    try it with the safety removed to determine that
     
  9. SeanTLog

    SeanTLog New Member

    13
    0
    0
    i appreciate yalls input it turned out to be the ambi saftey i have no idea why the ambi saftey would hangup the trigger but anyways i put the standard saftey selector back in and it is operating flawlessly. while i had the trigger assembly out i polished it up wth my dremel and it sweetened up the the trigger pull made it very crisp
     
  10. SeanTLog

    SeanTLog New Member

    13
    0
    0
    ok so i still have the problem but i figured out if you push the trigger forward after the shot it works fine. it makes a clicking sound when its pushed forward like its locking in. and its doing it every shot a real pain in the ass when trying to shoot. anyone ever had this problem
     
  11. stalkingbear

    stalkingbear Active Member

    4,078
    6
    38
    That's why I asked if you have the trigger return spring in properly. It's not resetting. Check your trigger spring again to ensure it's putting enough pressure against the trigger to reset it.
     
  12. deth502

    deth502 New Member

    137
    0
    0
    sounds like th disc is hanging up on the hammer.
     
  13. deth502

    deth502 New Member

    137
    0
    0
    abbreviation for "disconnector"
     
  14. slowryde45

    slowryde45 New Member

    1,198
    0
    0
    My vote is....the trigger spring.

    But if it were mine, I would probably take the whole trigger assembly out, and reassemble it, CORRECTLY, and make sure that all parts are present and installed correctly.

    That's not saying that you couldn't have got a mal-formed spring, or one leg too short, or whatever. Kaka happens, even to RRA lower parts kits ;)