Anyone elce have a remington 597?

Discussion in '.22 Rifle/Rimfire Discussion' started by fin24000, Oct 8, 2008.

  1. fin24000

    fin24000 New Member

    100
    0
    0
    Hey anyone else on here have a Remington 597 .22lr. I have one and I have an issue with it not ejecting all the way and getting jammed, now I know it isn't just me as I know a guy with the same issue and he even had the ejector spring replaced and it did not help.... so any thoughts?
     
  2. robocop10mm

    robocop10mm Lifetime Supporting Member Lifetime Supporter

    11,380
    2
    0
    I don't have a 597 but I do have a great deal of experience with RF rifles. The #1 problem is cleanliness. .22 LR is a very dirty round. Bullet lube and powder residue build up very quickly. Barring an obviously broken part the overwhelming cause of problems is dirt.

    Failure to eject is almost always an extractor issue. If the extractor(s) is gummy you WILL experience failures to eject. Flush out the bolt group and lightly lube, the problem will likely go away
     

  3. fin24000

    fin24000 New Member

    100
    0
    0
    Well I flooded it with rim oil a while back until the oil came back out clear and it helped for the first clip and that was it.... and since I shoot 3-5 clips at a time its really annoying.... as there anything I can do (other then getting a new .22 (don't mind more .22s but....)
     
  4. slwarren

    slwarren New Member

    49
    0
    0
    I just got one of these about a month ago, I went ahead and got the Volquartsen Remington 597 Target Hammer and extractor. I don't have much of a problem with extracting jams, but more with loading jams. I'm starting to wonder if it's my ammo. I'm using Federal right now, but I think I'm going to try something else.

    P.S.- I'm very happy with the Volquartsen parts, well worth the upgrade! especially the hammer.
     
  5. fin24000

    fin24000 New Member

    100
    0
    0
    Well I use federal all the time and have a tad better luck with CCI but its costs alot more....
     
  6. vanguard

    vanguard Member

    72
    0
    6
    i had the same problem, it is the two rail system they use , when that gits dirty i will not work right , it needs to be cleaned after every shoot.:)
     
  7. sgtdeath66

    sgtdeath66 New Member

    962
    0
    0
    i also have a 597 and had ejector problems until i changed to cci mini mags and maxi mags since then absolutly no probs hope this helps
     
  8. DuckA

    DuckA New Member

    97
    0
    0
    I guess mine is an oddball. The only problems I've had is when I put it back together incorrectly. I do tend to be a little OCD about cleaning my weapons though. I shoot Winchester Expert ammo.
     
  9. SoL

    SoL New Member

    120
    0
    0
    i got one of these in 22 magnum.

    Its basically depressing, flings em all over and is piping hot after 4 or 5 consecutive shots.

    dont get me started on the magazine feeding.
     
  10. cpttango30

    cpttango30 New Member

    13,934
    4
    0
    might want to head over to the Remington board on rim fire central. at http://www.rimfirecentral.com/

    There are some rather knowladgable 597 fanatics over there and I know they will have an answer to your question.