Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   Mini-14 Forum (http://www.firearmstalk.com/forums/f95/)
-   -   Mini 14 back from Ruger today (http://www.firearmstalk.com/forums/f95/mini-14-back-ruger-today-53473/)

louieboots 12-13-2011 12:44 AM

Mini 14 back from Ruger today
 
1 Attachment(s)
Took my mini out today fresh from Ruger and still having issues I used factory Ruger mags..it would shoot then not eject round like shown in the pic below.. When I used the ten rd mag they sent it back with loaded with .556 NATO shot all ten rounds flawless.. I only took 25 rds with me I'm gonna try some more rds tommorow and if it still gives me problems it will be sent back.. Please leave feed back thanks!

JTJ 12-13-2011 12:51 AM

Have you compared the flawless mag with your other mags?

shootitout 12-13-2011 12:53 AM

Sry to here your problem

louieboots 12-13-2011 01:26 AM

@jtj I did look the same one 5 rd ruger mag and and two 10 rounders

masterPsmith 12-14-2011 09:54 PM

Are you only having problems with ammo other than Nato ammo ???

Let me know what ammo you are having problems with and we can start from there.

By looking at the photo, it looks to be that it is a cyclic problem, possibly from a gas port obstruction or low gas port pressure. Nato ammo is loaded approx 10,000 psi higher than standard factory .223 ammo. If you have no problems with Nato ammo and are having problems with standard .223 ammo, then you are having gas pressure issues.

There could be other factors involved other than ammo issues.

If you are unable to solve the issue on your own, PM me for my phone number and we can go into detail over the phone. It would be easier than a long, drawn out process here on the forum. Then you can post the final result here.


Jim....................

Marlinman 12-14-2011 10:05 PM

Quote:

Originally Posted by masterPsmith
Are you only having problems with ammo other than Nato ammo ???

Let me know what ammo you are having problems with and we can start from there.

By looking at the photo, it looks to be that it is a cyclic problem, possibly from a gas port obstruction or low gas port pressure. Nato ammo is loaded approx 10,000 psi higher than standard factory .223 ammo. If you have no problems with Nato ammo and are having problems with standard .223 ammo, then you are having gas pressure issues.

There could be other factors involved other than ammo issues.

If you are unable to solve the issue on your own, PM me for my phone number and we can go into detail over the phone. It would be easier than a long, drawn out process here on the forum. Then you can post the final result here.

Jim....................

As he said it sounds like a gas issue and maybe a weak extractor spring also might be some of it also

God didnt make all men equal colonel sam colt did

Snakedriver 12-14-2011 11:29 PM

Most Mini's sling spent brass into the next county. Definitely a gas problem. How old is this gun?

louieboots 12-15-2011 12:10 AM

@masterpsmith the NATO .556 did shoot no problem.. I sent it back to Ruger again today with video and photo.. Hopefully they replace it..I tried Remington,Pmc,Winchester,and federal ammo in .223 they all failed..the rifle is brand new it's definitely a lemon..

louieboots 12-15-2011 12:12 AM

Thanks guys for the input I will let you know what happens when I get it back..

jismail 12-15-2011 05:05 PM

Most likely a silly question but have you dissasembled your action and ensured it is properly lubicated? New rifles ship with very minimal lubrication and some grease here and there will make the action much smoother and ensure you dont have unnessary wear on the parts.


All times are GMT. The time now is 06:08 PM.

Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.