Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   Range Report (http://www.firearmstalk.com/forums/f66/)
-   -   Colt sp6940 report (http://www.firearmstalk.com/forums/f66/colt-sp6940-report-46421/)

bluegrasstank66 08-08-2011 01:59 AM

Colt sp6940 report
 
Hey Everyone,

When out and shot my new colt today. Fired 320 rounds of PMC X-TAC m885 5.56 ammo. The rifle ran very well with only a minor complications which I believe are magazine problems and one scope problem.

Goods:
1. Despite hot rounds, there were no jams and the rifle worked very well.
2. Good ejection of the brass.

Concerns and Questions:
1. I was using 2 factory 20 round mags and 3 pmag 30 rounders. I started with the factory mags and then went through the pmags without a hiccup. Now, here is the problem and maybe this is just because I am still a beginner.

After reloading the mags, I started with the pmag. I put the magazine in (with the bolt forward, not back). I then pulled the charging handle in attempt to charge the round... nothing. The bolt went back forward but did not take a round with it. I then noticed that although the pmag seemed all the way up, it wasnt locked in. And despite everything I tried, it wouldn't lock. I then pull back the charging handle while simultaneously pushing up on the pmag. It partially grabbed a round causing it to jam and ruining the round.

So I then reloaded the factory metal mags and put one in the mag well (with the bolt forward). I pulled the charging handle and it charged the round completely fine. So was something going on with the pmags? Was it something I did to the pmags? Or am I missing something here? Any help is greatly appreciated because it got really annoying dealing with this!

2. I was using the Eotech EXPS 2-0 on my rifle with the Primary Arms deluxe 3x magnifier. Absolutely beautiful setup and a great reticle..... UNTIL after about 60 or 70 rounds the Eotech just TURNS OFF. It wouldnt turn back on for about 30 seconds. THEN it happens a second time after about 150 rounds! After that nothing was wrong. But WHAT THE HELL? I am going to be giving Eotech a call tomorrow chewing them out. Have people heard of this happening? Unreliability really makes me uneasy and for $500, they better get it damn right.

Overall, shooting my rifle for the first time was a great experience despite the few encounters along the way. And any help with any of those problems is greatly appreciated!

Thanks


All times are GMT. The time now is 11:36 AM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.