Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   Optics & Mounts (http://www.firearmstalk.com/forums/f65/)
-   -   Primary Arms Red Dot Problem (http://www.firearmstalk.com/forums/f65/primary-arms-red-dot-problem-62440/)

GREGULON 04-13-2012 09:06 AM

Primary Arms Red Dot Problem
 
So I bought the Primary Arms RD last week and today at the range I zeroed my irons and then co witnessed the dot. The I broke a three round set and the dot just jumped up and to the right. I repeated the process 2-3 more times with similar results. Them I just tapped the sight with my hand and it moved off target. I sent a email to PA's website. Has anyone else had this problem?

BenLuby 04-13-2012 12:31 PM

Quote:

Originally Posted by GREGULON (Post 769643)
So I bought the Primary Arms RD last week and today at the range I zeroed my irons and then co witnessed the dot. The I broke a three round set and the dot just jumped up and to the right. I repeated the process 2-3 more times with similar results. Them I just tapped the sight with my hand and it moved off target. I sent a email to PA's website. Has anyone else had this problem?

Similar, but not the same. Mine wouldn't adjust. Came in high to the left, and abso-freaking-lutely refused to move. Sent an email, and was thoroughly impressed with customer service. New one is on its way, with a return label for the bad one.
I think they got a batch of lemons.

GREGULON 04-13-2012 03:45 PM

So it just happened to you?

BenLuby 04-13-2012 06:35 PM

Quote:

Originally Posted by GREGULON (Post 769883)
So it just happened to you?

Yep. I'm actually sitting here waiting on my new RDS.

GREGULON 04-13-2012 08:59 PM

They just sent me a email saying a similar thing.

BenLuby 04-13-2012 10:16 PM

Quote:

Originally Posted by GREGULON (Post 770155)
They just sent me a email saying a similar thing.

Just hope they found the bad batch and that the replacement works.

GREGULON 04-17-2012 01:41 AM

Well its here but I am afraid it has the same problem, could it be a mount problem?

BenLuby 04-17-2012 03:30 AM

Quote:

Originally Posted by GREGULON (Post 773040)
Well its here but I am afraid it has the same problem, could it be a mount problem?

I won't know for sure until tomorrow when I test it out. If it has the same problem, then I am calling them again.

GREGULON 04-17-2012 06:01 AM

So I just tried out my original on a UTG Riser I bought for my scope and the dot didn't flinch at all so I think it has to be the cheap mount I put it on. It is a knock off of the KAC T1 mount. It breaks down into 4 parts, a top and bottom with 2 plastic spacers to skiers the height. I am leaving the country for 2 weeks so I can't do anything until I get back, but I think the Larue is the one I will try when I get back and I will get the UTG Riser also. The Daniel Defence is cool to. Let me know what happens.
Out

GREGULON 04-17-2012 06:04 AM

2 Attachment(s)
Attachment 43858



Attachment 43859

I think that the mount looks cool but it doesn't matter if it can't hold zero.


All times are GMT. The time now is 01:56 PM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.