Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   Optics & Mounts (http://www.firearmstalk.com/forums/f65/)
-   -   Bushnell 4 x 32 on Marlin 60 (http://www.firearmstalk.com/forums/f65/bushnell-4-x-32-marlin-60-a-54660/)

ktreffin 01-03-2012 01:36 AM

Bushnell 4 x 32 on Marlin 60
 
Hi folks,

I have been a member of this great community for a little while now, however this happens to be my first post. I have learned a TON since joining and I hope that one day I can develop the knowledge and experience to actually answer a few posts and participate more...

I have a question regarding a Bushnell 4x32 scope that I put on a Marlin Model 60 .22LR. I picked this scope up at Wally World (I know, you get what you pay for), however I thought the Bushnell name was reputable and the price was right. I got it all mounted up and zeroed it in and all seemed well until I noticed that the scope mounts seem to continuously loosen and the scope "walks" back...It's not actually the ring around the scope, its the dovetail that seems to loosen.

Could this be a problem with the mounts, or am I doing something wrong in mounting it? This has happened twice and the second time I cranked them on and it still loosened. Not nearly as bad as the first time, but enough to knock it off zero...

Anyone have any tips as to what I am doing wrong, or what I might try to make sure the dovetails stay put?

I appreciate the assistance! Thank you.

Ken

Axxe55 01-03-2012 01:41 AM

try some different rings. i used a simmons 3-9x40 on my M60 and it has the 1" tube. uses some weaver 1" dovetail rings for a grooved receiver. BTW, they are a two peice ring, mounted the rings, tightened and then mounted the scope. hope this helps.

ktreffin 01-03-2012 01:51 AM

Thanks Axxe.. I figured it might be the rings, but I wasn't sure if it was user error instead...I'll look into getting something a little better.

Marlinman 01-03-2012 01:51 AM

Try the weaver 22 solid dovetailed rings from walmart.

God didnt make all men equal colonel sam colt did

ktreffin 01-03-2012 01:52 AM

I will certainly look into those. Thanks!

Marlinman 01-03-2012 01:57 AM

1 Attachment(s)
They are normally black but heres the set on my 702 mossberg

Attachment 36901

God didnt make all men equal colonel sam colt did

Marlinman 01-03-2012 01:58 AM

Quote:

Originally Posted by ktreffin
I will certainly look into those. Thanks!

Your welcome

God didnt make all men equal colonel sam colt did

MidnightExpress 01-03-2012 02:29 AM

Quote:

Originally Posted by ktreffin (Post 665877)
I got it all mounted up and zeroed it in and all seemed well until I noticed that the scope mounts seem to continuously loosen and the scope "walks" back...It's not actually the ring around the scope, its the dovetail that seems to loosen.

That's actually a common issue with the Marlin semi-autos. The mount linked below should solve the problem, it did with mine and a lot of others over at Rimfire Central forums. Mine has over 1000 rounds through since the new mount was installed and hasn't moved a bit. It also helps to clear the paint from the dovetail.

UTG Leapers Accushot 1-Pc Mount w/1" Rings, 3/8" Dovetail. 1" rings.

ktreffin 01-04-2012 01:21 AM

Thanks Midnight! That mount looks like it will definitely work. Nice to know I am not the only one this has happened to.

jpattersonnh 01-05-2012 09:50 PM

I just put a drop of my wifes clear fingernail polish on the screws and tighten them. Does not budge.


All times are GMT. The time now is 01:41 AM.

Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.