Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   1911 Forum (http://www.firearmstalk.com/forums/f57/)
-   -   small issue with sig scorpion, failure to feed (http://www.firearmstalk.com/forums/f57/small-issue-sig-scorpion-failure-feed-59832/)

Dr. Marneaus 03-09-2012 06:17 PM

small issue with sig scorpion, failure to feed
 
So, after feeding it about 900 rounds, i've noticed one small issue on my new Sig Scorpion 1911.

I've been using all ball ammo, a few brands, federal, WWB, remington UMC, PMC, and Winchester SXZ or whatever. Issue has existed with all ammo i think.

Also using 2 factory mags, and 2 wilson combat mags. The issue still appears with both, but i feel like its MORE with the facotry mags.

95% of it feeds just fine. But ever so often I get a round that refuses to go fully into battery without assistance. The slide cycles, ejects just fine, then it strips the new round and stops about 3/8" from going into battery.

If i go to clear the malfunction with a "tap rack flip" the slide normally finishes seating as soon as I tap the mag. or i can reach up and nudge the slide with my thumb and it'll seat.

I just dumped about 700 rounds through the thing at front sight, and this would happen every few magazines. totally randomly, but never twice in a row. I had no other malfunctions, no stovepipes no type 3's, so i doubt im limp wristing or have severe magazine issues or anything.

Any idea what it could be? The first 3 days of the class the gun was stripped and cleaned a bit, wiped down the feed ramp and whatnot. The 4th day i didnt clean it, but that seemed to have no real bearing.

I suppose its possible its just not lubed enough or it was getting grimy, I'll see how it reacts when i get some froglube on it, but still, i feel like it shouldnt be doing that as much as it is.

suggestions on where to start?

Ranger-6 03-09-2012 06:43 PM

I have eliminated all FTF and FTE issues with all my guns:

1. Field strip and clean
2. Polish feed ramp to remove all paint, use 600 grit sandpaper
3. Grease the slide and rails, and light grease on ramp
4. Apply gun oil on all moving parts
5. Oil magazine and exercise float to properly seat and obtain freedom of movement
6. Straighten out forward guide tabs on magazines, not touching cartridge
7. Load magazines to capacity and let sit few days before shoot out
8. Apply oil to gun between rest periods, as needed
9. Check ammunition for deformities
10. Always inspect equipment before, during, and after every shoot

Dr. Marneaus 03-09-2012 06:46 PM

my initial thoughts were possibly about lubrication and whatnot, and i'll be solving that problem soon, currently all it's had on it is standard gun oil.

I was going to polish the feed ramp this weekend as well.

I've let the mags rest loaded to help exercise the springs.

glockman55 03-09-2012 06:58 PM

I've heard of this issue with the scorpion, do a google search on it. I have the newer sig. 1911, 22lr and it works flawlessly, about 600 rds through it. I have read that the mag. is the problem on your gun. Polish feed ramp to remove all paint, use 600 grit sandpaper, like suggested.
. Good Luck.

Dr. Marneaus 03-09-2012 07:15 PM

i'll polish the ramp this weekend for sure and see how it cycles.

I put a call in to sig and they said the first step is new mags, they're sending me 2. they said there was one other step after that before they bring the gun back in for a look.


All times are GMT. The time now is 05:37 AM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.