Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   1911 Forum (http://www.firearmstalk.com/forums/f57/)
-   -   RIA 1911A1 Issues (http://www.firearmstalk.com/forums/f57/ria-1911a1-issues-38654/)

CA357 02-18-2011 11:41 PM

RIA 1911A1 Issues
 
A while back, I sold my SR9c and used the cash to buy a new Rock Island 1911A1. Just the basic plain vanilla GI model.

Well, it had failure to feed issues. Bad.

I polished the feed ramp, but that didn't help. So, I sent it to Armscor in Pahrump, NV to have it fixed. The turn around time was excellent, the pistol was back to me in about three weeks, total time from the day I shipped it.

The throat & chamber were polished, ramp polished, extractor tuned and the recoil spring was replaced. This was after about 5-600 rounds.

I got it back and took it to the range last Saturday. It still won't feed right. I called Armscor and spoke with Dave the gunsmith and sent it back again on Tuesday.

BTW, it is not a magazine issue. It FTF'd with Kimber, McCormick, Wilson, Tripp and the factory supplied Act-Mag.

One other thing, RIA doesn't provide a shipping tag. Dave said he'd do something to make it up.

I'll let you know how things turn out.

canebrake 02-18-2011 11:48 PM

Didn't you have trouble with another RIA?

danf_fl 02-18-2011 11:55 PM

Did you ship some of your ammo, too?

HOSSFLY 02-19-2011 12:23 AM

Quote:

Originally Posted by CA357 (Post 448439)
A while back, I sold my SR9c and used the cash to buy a new Rock Island 1911A1. Just the basic plain vanilla GI model.

Well, it had failure to feed issues. Bad.

I polished the feed ramp, but that didn't help. So, I sent it to Armscor in Pahrump, NV to have it fixed. The turn around time was excellent, the pistol was back to me in about three weeks, total time from the day I shipped it.

The throat & chamber were polished, ramp polished, extractor tuned and the recoil spring was replaced. This was after about 5-600 rounds.

I got it back and took it to the range last Saturday. It still won't feed right. I called Armscor and spoke with Dave the gunsmith and sent it back again on Tuesday.

BTW, it is not a magazine issue. It FTF'd with Kimber, McCormick, Wilson, Tripp and the factory supplied Act-Mag.

One other thing, RIA doesn't provide a shipping tag. Dave said he'd do something to make it up.

I'll let you know how things turn out.

I had the same problem with the same model gun-
Did all i could do (about what Armscor did to yours) & same problem - Mine was FTF on FIRST round from mag only- ANY mag-
Anyway I started running it "WET" & shooting it a lot-
MUCH better now :rolleyes:

CA357 02-19-2011 12:27 AM

Yes, my only other RIA was a Tactical model a couple of years back and it wouldn't feed either. I sold it post haste.

I figured with all the "I love my RIA" posts and threads that I'd give it another go. I mean I couldn't get two lemons, right?

It is not operator error or a magazine issue. It is definitely something with the pistol itself.

I've owned an SA Mil Spec, a Baer TRS, a Dan Wesson CBOB and my Sistema. None have had the issues the two RIA's have had. Maybe I'm just snakebit when it comes to the Rock Islands?

Tons of folks have them and love them, so my luck must just be bad with them.

The thing is that I could have spent the same money on a Sistema that had peen reparkerized, but didn't want to buy something that might turn into another project pistol.

CA357 02-19-2011 12:30 AM

Quote:

Originally Posted by danf_fl (Post 448447)
Did you ship some of your ammo, too?

All common and all 230gr. ball. Blazer, Blazer Brass, WWB, S&B, and Fiocchi.

I bought it to shoot hardball ammo through. I only shoot 230gr. ball ammo in my 1911's. If that doesn't do the job, I either need a long gun or to run like hell.

danf_fl 02-19-2011 12:49 AM

I have not had a problem with my RIA (.38Super) feeding in the 150 rounds I've put through it.

Shihan 02-19-2011 01:24 AM

Must be the ones they send to California. I have never had an issue with my Full size plain jane GI. SHoots everything even with the ActMag. Sorry to hear that, hope their customer service helps you out.

CA357 02-19-2011 05:07 AM

The round just noses into the feed ramp. :(

When I get it back, I'm going to shoot the hell out of it, then, it it's still not dependable, I'll see if the shop still has that reparked Sistema and how much they'll give me in trade. I know what a Sistema is capable of and I'd trust it.

mudslinger79 02-19-2011 11:24 AM

I've been having a similar issue with my Taurus lately. With hollow point ammo. It would noise dive that first round into the chamber. Tried a different ammo. Federeal hydra-shock, its only done it a few times. I have 3 mags for it and the ACT-MAG works best. Even better than the Chip McCormick. I have been keeping it cocked and locked because that seems to make it run. Also if I load 7 in the mag instead of 8 its fine. Im thinking on doing a slight polish on the feed ramp and staying away from wide mouth hollow points to see what happens.


All times are GMT. The time now is 03:40 AM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.