Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   Glock Forum (http://www.firearmstalk.com/forums/f56/)
-   -   Massive failure to feeds G26 Gen4 (http://www.firearmstalk.com/forums/f56/massive-failure-feeds-g26-gen4-52824/)

wcohio 12-01-2011 12:05 AM

Massive failure to feeds G26 Gen4
 
My glock 26 gen 4 9mm is brand new. I just chambered it the first time today. First time it failed to feed. I figured it was just because it was a hollowpoint round, so I tried again, and it failed again. I cycled thru a whole magazine of Hornady HP and they all failed to feed. Next up was a box of jacketed ammo. Every other round failed to feed. After the jam, I only needed to pull back slightly and release and the round fed the rest of the way. Don't see any obvious signs of wear on the feed ramp; looks brand new as it should. Any ideas what's going on?

Firearms4ever 12-01-2011 12:14 AM

Sounds like it could be the magazine. Do you have another magazine you could try?

wcohio 12-01-2011 12:25 AM

Tried two of the three factory mags that came with the gun... both with same results

Firearms4ever 12-01-2011 12:32 AM

Hmmm, were you using the same brand of ammunition with the FMJ and the Hollow Points?

wcohio 12-01-2011 01:27 AM

Yeah, both are Hornady

Firearms4ever 12-01-2011 10:26 AM

I would recommend trying another brand of ammunition and see if that's the problem.

robocop10mm 12-01-2011 11:22 AM

Were you shooting or just cycling the ammo through? Slightly riding the slide forward can and will induce malfunctuons like this.

Byron0022 12-01-2011 01:19 PM

Isn't there a recall on the springs in the Gen 4s?

wcohio 12-01-2011 03:47 PM

Was shooting... not just cycling by hand... however, when chambering it jammed also. I pulled back on the slide all the way and let go. It's making me sick, honestly. I thought for sure this would be a decent auto. I recently got rid of a Taurus 9mm that was severely inaccurate, but at least it fed every time. I spent $550 on this Glock and it's not doing well so far.

Firearms4ever 12-01-2011 04:12 PM

So far it sounds like it could be either the particular ammunition given that it was the same brand or the feed ramp.


All times are GMT. The time now is 09:55 AM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.