Firearm & Gun Forum - FireArmsTalk.com > Handguns > Semi-Auto Handguns > Glock Forum > Glock 26 gen 4 problems

Reply
 
LinkBack Thread Tools Display Modes
Old 07-02-2012, 02:46 PM   #1
Feedback Score: 0 reviews
 
GLKmiester's Avatar
 
Join Date: Nov 2011
Posts: 63
Liked 8 Times on 7 Posts

Default

Hello, I've been shooting glocks for about 6 years now. I've owned the 27 and the 21. I now own the gen 4 17 and 26.

My 26 has around 500 rounds down the pipe. It has given me no problems until yesterday. We were shooting wwb ammo with the factory 10 round mag. Near the end of the session the slide started locking back halfway through the mag. It did this to me and my friends. It kept doing this and towards the end it was locking back every other round.

I know that an improper grip can cause this but since I've never had this problem before I think it's mechanical. Does anyone know what could be causing this? Thanks for any help.



__________________
GLKmiester is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 07-02-2012, 03:55 PM   #2
Feedback Score: 0 reviews
 
kodiak's Avatar
 
Join Date: Jan 2012
Posts: 99
Liked 12 Times on 9 Posts
Likes Given: 3

Default

Did you both install new SSL's and put it back together incorrectly?



__________________
kodiak is offline  
 
Reply With Quote
Old 07-02-2012, 03:56 PM   #3
Feedback Score: 0 reviews
 
GLKmiester's Avatar
 
Join Date: Nov 2011
Posts: 63
Liked 8 Times on 7 Posts

Default

Everything on my glock is factory original.

__________________
GLKmiester is offline  
 
Reply With Quote
Old 07-02-2012, 04:03 PM   #4
Feedback Score: 0 reviews
 
kodiak's Avatar
 
Join Date: Jan 2012
Posts: 99
Liked 12 Times on 9 Posts
Likes Given: 3

Default

Alright let me rephrase, did you and your buddy detail strip your Glock at anytime? Check to see if your slide stop lever spring is under the locking block pin (top pin).

__________________
kodiak is offline  
Wiebelhaus Likes This 
Reply With Quote
Old 07-02-2012, 04:06 PM   #5
Feedback Score: 0 reviews
 
GLKmiester's Avatar
 
Join Date: Nov 2011
Posts: 63
Liked 8 Times on 7 Posts

Default

I have detail stripped my glock once. It ran fine afterwards. That was about 200 rounds ago. Although, I will check that out when I get home from work.

__________________
GLKmiester is offline  
 
Reply With Quote
Old 07-02-2012, 04:13 PM   #6
Feedback Score: 0 reviews
 
kodiak's Avatar
 
Join Date: Jan 2012
Posts: 99
Liked 12 Times on 9 Posts
Likes Given: 3

Default

Alright let us know. I'm betting that's the problem, if it's not your grip.

__________________
kodiak is offline  
 
Reply With Quote
Old 07-02-2012, 04:24 PM   #7
Feedback Score: 0 reviews
 
GLKmiester's Avatar
 
Join Date: Nov 2011
Posts: 63
Liked 8 Times on 7 Posts

Default

I hope it is something simple like that too. Thanks.

__________________
GLKmiester is offline  
 
Reply With Quote
Old 07-02-2012, 09:22 PM   #8
Feedback Score: 0 reviews
 
GLKmiester's Avatar
 
Join Date: Nov 2011
Posts: 63
Liked 8 Times on 7 Posts

Default

I took the slide off and this is what I saw. Do you think the spring will be salvageable?

image-3191708532.jpg  
__________________
GLKmiester is offline  
 
Reply With Quote
Old 07-02-2012, 09:54 PM   #9
Feedback Score: 0 reviews
 
kodiak's Avatar
 
Join Date: Jan 2012
Posts: 99
Liked 12 Times on 9 Posts
Likes Given: 3

Default

Quote:
Originally Posted by GLKmiester
I took the slide off and this is what I saw. Do you think the spring will be salvageable?
Don't know, take it out and reinstall it properly. In the interim just go ahead and order a new SSL. Chalk it up to a lesson learned, bet you don't do that again
__________________
kodiak is offline  
 
Reply With Quote
Old 07-03-2012, 03:47 AM   #10
Feedback Score: 0 reviews
 
GLKmiester's Avatar
 
Join Date: Nov 2011
Posts: 63
Liked 8 Times on 7 Posts

Default

Quote:
Originally Posted by kodiak

Don't know, take it out and reinstall it properly. In the interim just go ahead and order a new SSL. Chalk it up to a lesson learned, bet you don't do that again
Thanks. I did reinstall it after reviewing some detail strip videos. I'm not sure what I did wrong though. I would like to know so I don't have to worry about it ever happening again.


__________________
GLKmiester is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
Glock problems BigBeau45 Glock Forum 7 01-28-2012 12:41 AM
Glock problems mjfash55 Glock Forum 17 08-13-2011 07:22 PM
Gen 4 Glock problems, not worth the buy? indyfan Glock Forum 3 05-19-2011 03:26 AM
Problems with Glock 17 Gen 4 recoil spring Fourbits Glock Forum 2 07-13-2010 05:36 PM
New Glock Problems??? MeanChad Glock Forum 14 10-15-2008 10:10 PM