stevens model 67/12 gauge pump -fail to eject


Firearm & Gun Forum - FireArmsTalk.com > Gunsmithing & Do-It-Yourself Projects > Gunsmithing Forum > stevens model 67/12 gauge pump -fail to eject

Reply
 
LinkBack Thread Tools Display Modes
Old 05-18-2011, 07:12 AM   #1
Feedback Score: 0 reviews
 
Join Date: May 2011
Location: michigan
Posts: 2
Default stevens model 67/12 gauge pump -fail to eject

hello to all,
im new here and looking for answers obviously!!
got an ol' model 67 stevens im redoing, and the thing isnt wanting to eject shells. now, i thought i had diagnosed the issue, and replaced the ejector, but alas.....it wasnt the issue. now upon closer inspection, and had i been paying closer attention, it seems, that perhaps the culprit, or should i say culprits, were the extractors. seems they feed the shell nicely into the chamber, and pull it out every time, but once to the rear of the receiver where the shell should make contact with the ejector they let loose of the shell so that it will not eject from the receiver. now i guess my question is this....does that sound like a reasonable diagnosis or am i missing something? just second guessing my self, and trying to be sure. the little itty bity parts for replacement are a little pricey so id like to get it right. any and all help/advice will be most appreciated.
thank you much!!!



__________________
tedfeast is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 05-18-2011, 02:35 PM   #2
Feedback Score: 0 reviews
 
hiwall's Avatar
 
Join Date: May 2011
Location: Cleator,AZ
Posts: 3,342
Liked 743 Times on 473 Posts
Likes Given: 232

Default

Is there crud built up in the extractors so they don't have full movement? Are the extractor springs broken or weak?



__________________

Just walking on the edge of of my grave.

hiwall is offline  
 
Reply With Quote
Old 05-18-2011, 03:35 PM   #3
Feedback Score: 0 reviews
 
stalkingbear's Avatar
 
Join Date: Sep 2007
Location: Lebanon,Ky
Posts: 3,621
Liked 11 Times on 10 Posts
Likes Given: 3

Default

If the extractors & springs are not worn I'd look close at the ejector. If the extractors are pulling the empty shell out good it almost has to be the ejector.

__________________

Sometimes you earthlings REALLY amaze me!

stalkingbear is offline  
 
Reply With Quote
Old 05-19-2011, 01:55 PM   #4
Feedback Score: 0 reviews
 
Join Date: May 2011
Location: michigan
Posts: 2
Default

i already replaced the ejector. that was my first inclination as to the problem. the ejector does function, but i think the extractors are not holding the shell in place properly for the ejector to do its job. it kicks the shell loose, just not out of the gun. i really think its worn extractors, but i was just looking for some back up on my theory. thanks a million for all your advice though. please keep it coming!!!

__________________
tedfeast is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
Savage 755a Semi automatic 12 gauge Shotgun and Stevens Model 67 Pump action 410gauge firejeff67 General Shotgun Discussion 4 12-01-2012 01:08 PM
Fail to eject in .303 and also AR-15 rangeshooter General Rifle Discussion 8 05-22-2010 11:50 AM
Escort 12 Gauge Pump patrilogical Range Report 3 01-30-2010 07:31 AM
Stevens model 79 in 410 spittinfire General Shotgun Discussion 5 10-21-2009 11:13 AM
Recomendations for youth 20 gauge pump Megaton General Shotgun Discussion 8 09-11-2009 08:32 PM