Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   Gunsmithing Forum (http://www.firearmstalk.com/forums/f33/)
-   -   SAA Clone Won't Range (http://www.firearmstalk.com/forums/f33/saa-clone-wont-range-30789/)

Hill_Country_Gunsmith 08-23-2010 09:34 PM

SAA Clone Won't Range
 
I have a Uberti Colt SAA in my shop that will not range, i.e. the cylinder is not lining up with the bore properly. I make my living working on these things but this one seriously has me stumped. I have tried too many repair options to list. Any help would be appreciated.

danf_fl 08-23-2010 09:52 PM

I had something like that come through. The "hand"/"pawl" was not the proper length for indexing the cylinder correctly (a tad too long in my case). Someone put a different hand in that was the wrong part, so first cursory look did not see anything obviously broken.
Do you have any pictures?
(Oh, we also ask that new members stop by the "Introductions" area and say "HI")

Hill_Country_Gunsmith 08-23-2010 10:18 PM

Yeah, I've shortened the hand to facilitate the revolvernot traveling as far clockwise but this just creates a lot of cylinder wobble when the gun is cocked. I' also tried fitting 2 new bolts...

danf_fl 08-23-2010 10:21 PM

How is the cylinder end play?

Hill_Country_Gunsmith 08-23-2010 10:50 PM

Aprrox. .005" endshake

danf_fl 08-23-2010 11:45 PM

Is it possible that the cylinder is not original?

Hill_Country_Gunsmith 08-24-2010 01:32 AM

I also replaced the cylinder which was unnecessary because it has the exact same dimensions as the original. I thought the bolt stop notches might be machined incorrectly. The throats on the cylinder are actually oversize so it's not that the front holes are too small. Also, the bore and forcing cone look good and the frame is not bent. Told you it had me stumped... I'm going back to the shop to try again.

Dillinger 08-24-2010 01:35 AM

Welcome Hill Coutry - This is not my area, but we have a couple of revolver guru's on the board that might be able to help.

I have sent up the flare, so they should be stopping by shortly.

JD

stalkingbear 08-24-2010 04:04 AM

Have you already tried replacing the hand and cyl latch? Is the latch securely locking the cyl when you rotate it by hand? If so then you need a longer pawl. Try bending the pawl and see if that helps. It sounds like a simple timing problem. Please let me know what all you've done so far. Also is the cyl dead in the middle of the frame? What about the base pin? Is the pawl slot in the frame in exactly the right place? Feel free to PM me.

danf_fl 08-25-2010 10:14 PM

Any updates?


All times are GMT. The time now is 04:51 AM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.