Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   Gunsmithing Forum (http://www.firearmstalk.com/forums/f33/)
-   -   Norinco T-54-1 Tokarev Clone Trigger Problem Fixed (http://www.firearmstalk.com/forums/f33/norinco-t-54-1-tokarev-clone-trigger-problem-fixed-74136/)

CPFarmer 10-11-2012 05:35 PM

Norinco T-54-1 Tokarev Clone Trigger Problem Fixed
 
I recently purchased a T-54 at an estate auction for $75.00 (which was cheap considering a Yugo SKS went for $750.00). The gun looked a little rough, but I figured that for that price, what the heck, why not. So I take the gun home and begin to give it a more detailed look over, considering this was my first Tokarev. I cycled the slide and blocked the hammer to check the trigger pull and function, as well as make sure the slide catch held. On about the third slide cycle, the trigger acted as if it were jammed. It would only move a 32nd of an inch or so, and the sear wouldn't trip. So I cycled the slide a few more times, and the trigger started working again. However, there was a new malfunction, and a serious one at that. Now the trigger could be pulled at half cock, and the hammer would drop.

So I sat down to disassemble, clean, and inspect the gun. Once torn down, I noticed the internals looked pretty good, having a coating on mainly dust and dried oil inside. It looked as if the gun was purchased shortly after import (1964), shot a few times and then thrown under a couch where it would sit for 30 or so years. I gave it a fairly thorough cleaning, using a whole can of brake clean, some compressed air, and brushes, followed by a good oil down. On reassembly, everything seemed to function normally. So thinking all was well, I took it out back to my range.

The first three rounds went with no problem, then a misfire occurred. I cycled the slide and it fired 2 more rounds, then misfired again. On examining the brass, I noticed the primers had a hole in them, so I changed ammo, and cleared the little bits of primer from the gun, including the one over the firing pin. Then the trigger jamming started again. It would fire alright if rounds were loaded into the breach one at a time, with the magazine in to latch the slide back after each round. After 10 or so rounds, the slide failed to return to battery, stopping about 2/3 closed. The slide would come back, but would not close. So I tried to get the magazine out, and it was stuck, The magazine latch would release it, but it would only move about a 32nd of an inch, and when the slide was pulled back, it would move a little more, but would pull back into the magazine well when the slide moved forward to the jammed position. I guessed that the magazine follower had come loose and was jamming it, and later was able to determine this was actually the problem, with the front of the followers getting on top if the slide catch, not allowing it to be depressed. So back inside to see what was going on.

After a little work, I got it disassembled again, and inspected it once more. I was looking for anything cracked or broken, or jammed. I checked the grips, as I have read that they guide the trigger linkage, and can be a problem if worn or chipped. The guides looked good, so I reassembled it without the grips to get a look at the trigger mechanism when cycled. With the magazine out, and trigger depressed, I cycled the slide a few times to check the linkage. The first few times when the slide had returned to battery, there was a crisp click as the release of the trigger let the linkage rise back up and engage the sear after the disconnect had pushed the linkage down during slide movement. Then the click disappeared and the problem with sear releasing at half cock started again.

So I tore it down again, looking mainly at the hammer assembly. I could get it to drop the hammer from half cock on occasion, so I decided to strip the hammer assembly down for a closer look, something I didn't do before. After removing sear, and disconnect, I finally saw what was going on. There on the disconnect, the cylindrical part that comes up through the hammer assembly and is depressed by the slide, was a small glint. It was almost microscopic, but it was firmly stuck to the disconnect. After clearing the piece of metal and reassembling the hammer assembly, I finally figured out what was happening. When the disconnect tried to travel to the full up position, it sometimes didn't quite make it all the way due to the small bit of metal jamming it. In this position, the disconnect held the sear in such a position, that it couldn't completely engage the half cock notch in the hammer, and wasn't stopping the sear from returning fully to the fire position, instead it only caught the edge of it, making it possible to drop the hammer at half cock.

Sorry this is so long winded, but I wanted to give as much detail as possible in case anyone else experiences the same malfunction.

Since reassembly, everything works flawlessly.

danf_fl 10-11-2012 06:59 PM

Thanks for the input.
May I suggest that you do not use brake cleaner, but carb cleaner instead.
Brake cleaner leaves a residue that, should it get hot enough, could cause respiratory problems.
http://www.ehow.com/list_5954441_dangers-brake-cleaner_.html

Not that carb cleaners are any better:
http://www.ehow.com/list_6029898_ingredients-carburetor-cleaners.html

CPFarmer 10-12-2012 02:06 PM

A good point you make on using aerosol cleaners. Actually, both can causes respiratory issues and other health problems, and both are highly flammable. I use brake cleaner, because in my drag racing days, I noticed the carburetor cleaner left a residue on highly polished surfaces, such as crankshaft mains and journals, but the brake cleaner didn't. But that's just my preference. Either way, both should be handled with care. When I have parts to clean at home, I take them outside in a screen basket to a bench some 10 feet from the door, so that fumes won't get into the house, and blow them off with dry compressed air. Taking parts back into a house with residue still evaporating could also draw the ire of a spouse. Once the Mrs. gets a whiff of cleaner, look out, you'll be in the dog house for sure.

Another use for carburetor cleaner is as a starting fluid substitute. I've started several of my diesels with it, when I was out of Ether.


All times are GMT. The time now is 01:44 PM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.