Firearm & Gun Forum - FireArmsTalk.com > Gunsmithing & Do-It-Yourself Projects > Gunsmithing Forum > M1 Garand feeding issue

Reply
 
LinkBack Thread Tools Display Modes
Old 01-21-2013, 06:27 PM   #1
Feedback Score: 0 reviews
 
GunsmithCat's Avatar
 
Join Date: Nov 2012
Posts: 7
Default M1 Garand feeding issue

Hey guys,

Not sure if this is the correct forum, but as it relates to feeding problems I put it here in gunsmithing.

Anyways, the problem is it feeds & fires the first 4 rounds flawlessly. But after the 4th round fires, the en bloc magazine partially ejects, jamming the slide and displacing the remaining rounds.

I've replaced the bullet guide as recommended previously to me but the problem persists.

Any ideas?

Thanks



__________________
GunsmithCat is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 01-21-2013, 09:23 PM   #2
Welcoming Committee/ Resident Pellet Gunner
Feedback Score: 0 reviews
 
FullautoUSA's Avatar
 
Join Date: Aug 2012
Location: Marxachusetts
Posts: 2,627
Liked 621 Times on 473 Posts
Likes Given: 1111

Default

Is this happening on every clip or just one?
The Garand doesn't use a magazine it uses a clip



__________________
LIVE FREE OR DIE

[COLOR="Blue"]See my pellet guns here: http://www.firearmstalk.com/forums/groups/ftf%20pellet%20gunners/air%20gun%20picture%20thread-149/

RESIDENT AIR GUN GUY
FullautoUSA is offline  
 
Reply With Quote
Old 01-21-2013, 11:50 PM   #3
Feedback Score: 0 reviews
 
Join Date: May 2009
Posts: 168
Liked 14 Times on 14 Posts
Likes Given: 5

Default

Its a common issue with the Garand and a simple fix.
95% of the time its a weak clip latch spring
Next could be enblocs then the bullet guide. It can also be a few other less common things
What is stamped on the bottom of the eblocs you are using
Pull out the clip latch spring, stretch the spring and reinstall. Fire rifle again ,if issues are gone the order a replacement from Orion 7 or Fulton Armory
Problem fixed

__________________
Orlando is offline  
 
Reply With Quote
Old 01-27-2013, 02:33 AM   #4
Feedback Score: 0 reviews
 
Join Date: Jan 2013
Posts: 1
Default

+1 for this^^^ my M1 did the exact same thing. What I did was "borrow" my brothers M1 and started swapping parts until it stopped malfunctioning. I don't remember what part did the trick but start with the least expensive fix and work your way up

__________________
mausermolt is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
AR or AK, feeding the hungry... TankTop AK & SKS Discussion 14 12-23-2012 09:48 PM
mp9 feeding niteglock M&P Forum 1 10-22-2012 12:26 AM
SKS feeding issue Nihilist88 AK & SKS Discussion 11 05-05-2012 02:59 PM
Feeding issue GonzoLonzo .22 Rifle/Rimfire Discussion 10 01-17-2012 04:43 PM
Issues with feeding Shooter girl Ammunition & Reloading 24 11-30-2009 12:01 PM



Newest Threads