Firearm & Gun Forum - FireArmsTalk.com > Gunsmithing & Do-It-Yourself Projects > Gunsmithing Forum > hi..new member here

Reply
 
LinkBack Thread Tools Display Modes
Old 09-03-2009, 05:24 AM   #1
Feedback Score: 0 reviews
 
Join Date: Sep 2009
Posts: 4
Default hi..new member here

hello,
just signed up,like to say hi to everyone and thanks for any advice or education i may get,and if i can contribute in any way i will.
pretty new to firearms,i have been shooting for years but i never really dissassembled or refinished any.i have lately gotten into stock refinishing.
i am very religous about cleaning and storing all my firearms,and i have never had a problem...ever with any of them.they always fire and eject as exspected.
i however have a vexing problem with a s/w 645
a friend gave it to me for a gift(birthday)last year,i really like the gun,i like how it fits my hand,i am somewhat accurate with it,and i love stainless handguns.
it has actually has me into gunsmithing because of the problem it has.
i can shoot a magazine through it one time,everything works flawlessly..then with no rhyme nor reason,it will out of the blue..fire multible rounds with a pulll of the trigger.not only do i find it disconcerting when it happens but i feel it is a dangerous condition.from what i understand it is firing out of battery?i tried rotating magazines,to no effect.i have dissassembled it down to every component and cleaned and lubed,and it stills does this.i studied the schematic for it and the only thing i can think of is possibly the sear is worn?
am i missing something obvious,or should i just buy a new sear?can anyone help me with this..i will not shoot the firearm in this condition but i would like to fix it myself,as i have now had it apart so often i can assemble it with my eyes closed.
no offence to gunsmiths but i would like to fix it myself,i replaced a few components(the levers or whatever you would call them)cant think of the names of the parts off the top of my head,but this is my first problem/project.
i looked over the schematic and some of the levers/disconnect/pieces looked worn so i replaced them.i did not touch/change any springs though.
i just cant understand why it would be as random as it is if it was a spring,i would think it would either work or not?
i guess i could think the same about the sear.
any help would be appreciated,and thanks in advance.

__________________
dpanc60 is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 09-03-2009, 09:04 AM   #2
Feedback Score: 0 reviews
 
Join Date: Dec 2007
Posts: 7,152
Liked 21 Times on 7 Posts

Default

T'was I a betting man, I'd wager that some home gunsmithing created the problems you have with this gun. Early S&W autos aren't known for their crisp & light trigger pull so many folks attempt home "trigger jobs" and this can be the result. Cutting coils off springs to lighten pull, filing engagement surfaces, and other "remedies" can lead to serious problems. Before I offer any advice I'll state up front that this gun needs to go to a competent gunsmith. As a minimum, I'd replace ALL springs as a starting point as you'll have no idea if any were modified. Anyway, here's a few things to check.

I had one some years ago but I don't remember that much about the mechanics of it. From your symptoms, things I'd look at are a worn sear, worn hammer (maybe both), some gunk in the firing pin tunnel not allowing the firing pin to retract fully, weak or modified (cut) springs, etc.

One thing to try is to take out the mag, be sure the gun is clear, and from a dropped hammer rack and release the slide quickly. Repeat a bunch of times to see if the hammer ever follows the slide. If it does then the sear isn't engaging properly. Also, after doing this for a time (dropping the hammer each time), see if the firing pin is protruding from the breech face.

One of two things is probably happening, the hammer/sear are not engaging properly OR the firing pin is protruding (not retracting fully) causing a slam fire. It is NOT safe to fire this gun in this condition and you should take it to a qualified gunsmith. I'll say it again: home gunsmithing, especially if you're not experienced, can cause more problems than it solves - and end up being more expensive. It's also dangerous as you can end up with a gun that goes full-auto as yours does.

Besides the safety issue, a gun going full-auto can also get you in some serious legal trouble if it does so in front of the wrong folks. You may be paid a visit by the feds - they might want to know why you "built" a class 3 weapon without a license.

BTW, if you intend to stick around, pop on over to the introductions area and tell us a little about yourself...

__________________

Last edited by NGIB; 09-03-2009 at 09:52 AM.
NGIB is offline  
 
Reply With Quote
Old 09-08-2009, 01:45 AM   #3
Feedback Score: 0 reviews
 
Join Date: Sep 2009
Posts: 4
Default thanks for the advice

hi,
tried doing what you said with the firearm,empty chamber,no mag.did what you exsplained,assuming with the decocker in the fire position.(with decocker down( it just follows /drops hammer)
the hammer does not follow the slide as you indicated it may,however,if i attempt to pull slide back with hammer in fire position it drops the hammer as i pull the slide back?
i also pulled the slide and inspected the position of the firing pin..i could not get the pin to protrude past the face of the slide,definately not going to slam fire,which i thought sounded very reasonable for my problem.i depressed it from the rear with a punch.
gonna have to take it to a smith i guess,but thanks for your insight/help.
what a vexing problem...hell i couldnt figure out how to even diss assemble the the pin from the slide..lol.
thanks again though.

__________________
dpanc60 is offline  
 
Reply With Quote
Old 09-08-2009, 09:04 PM   #4
Feedback Score: 0 reviews
 
stalkingbear's Avatar
 
Join Date: Sep 2007
Location: Lebanon,Ky
Posts: 3,621
Liked 10 Times on 9 Posts
Likes Given: 3

Default

Everything NGIB said. You could fix it by installing factory new hammer, sear, and springs without touching them other than to install them.

__________________

Sometimes you earthlings REALLY amaze me!

stalkingbear is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
new member jeremy8302 Semi-Auto Handguns 4 10-27-2008 11:48 AM