Brand New Rock Island M5 pump, click but no bang


Firearm & Gun Forum - FireArmsTalk.com > Long Guns > General Shotgun Discussion > Brand New Rock Island M5 pump, click but no bang

Reply
 
LinkBack Thread Tools Display Modes
Old 01-08-2013, 04:47 AM   #1
Feedback Score: 0 reviews
 
GunLover1969's Avatar
 
Join Date: Apr 2012
Posts: 29
Liked 3 Times on 2 Posts

Default Brand New Rock Island M5 pump, click but no bang

I was wondering if there might be a simple fix a shotgun expert might know of...

My new pump action shotgun shoots sometimes, other times there's a click, but no bang.

Firing pin not striking? Set wrong? Head space? Any clues? It's brand new!



__________________
GunLover1969 is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 01-09-2013, 01:01 AM   #2
Feedback Score: 0 reviews
 
Blueguns's Avatar
 
Join Date: May 2012
Location: 2,000 miles Northwest of Bill's Laundromat, Bar & Grill, CA
Posts: 2,001
Liked 538 Times on 379 Posts
Likes Given: 273

Default

Quote:
Originally Posted by GunLover1969
I was wondering if there might be a simple fix a shotgun expert might know of...

My new pump action shotgun shoots sometimes, other times there's a click, but no bang.

Firing pin not striking? Set wrong? Head space? Any clues? It's brand new!
Sounds like a light strike of the firing pin. What ammo are you using?


__________________

-Matt

Blueguns is offline  
 
Reply With Quote
Old 01-09-2013, 01:24 AM   #3
Feedback Score: 0 reviews
 
GunLover1969's Avatar
 
Join Date: Apr 2012
Posts: 29
Liked 3 Times on 2 Posts

Default

Was using Federal Target Load.


Didn't have any problems with 3 other shotguns, just the M5.

Has to be something with the firing pin then I assume.

__________________
GunLover1969 is offline  
 
Reply With Quote
Old 01-09-2013, 04:56 PM   #4
Feedback Score: 0 reviews
 
Blueguns's Avatar
 
Join Date: May 2012
Location: 2,000 miles Northwest of Bill's Laundromat, Bar & Grill, CA
Posts: 2,001
Liked 538 Times on 379 Posts
Likes Given: 273

Default

Quote:
Originally Posted by GunLover1969
Was using Federal Target Load.

Didn't have any problems with 3 other shotguns, just the M5.

Has to be something with the firing pin then I assume.
Federal is pretty tried and true, sounds like a firing pin issue. I'd take it to a smith.
__________________

-Matt

Blueguns is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
rock island juststartin5272 1911 Forum 17 09-26-2012 10:04 PM
Rock Island? Tom86 1911 Forum 48 05-04-2012 07:36 PM
Rock Island Hawg 1911 Forum 14 01-08-2012 10:18 PM
Rock island Upon1cbr 1911 Forum 22 10-11-2011 12:25 AM
Rock Island lukeisme 1911 Forum 13 01-31-2010 05:56 AM