Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   .22 Rifle/Rimfire Discussion (http://www.firearmstalk.com/forums/f21/)
-   -   Winchester Model 74 (http://www.firearmstalk.com/forums/f21/winchester-model-74-a-26632/)

evo9guy 04-30-2010 02:11 AM

Winchester Model 74
 
Hello all,

Recently acquired a Model 74 from my dad, chambered in .22 LR, and I am having a problem with the bolt. I have not been able to find a schematic or a exploded parts view online (well one that is free anyway) and was wondering if anybody could help out with one.

Or...

The reason for the above request, the rifle will fire perfect; however, when loading the rifle with a round the bolt does not travel back far enough to charge the trigger. There will be a round in the chamber, but when you pull the trigger, nothing. Pull the charging handle again, out comes previous round, new round enters chamber, take aim, pull trigger, nothing. After about five or six tries the rifle will fire and from there wil go through the remaining rounds. When the rest of the rounds are done, the process starts all over again.

I have a feeling it needs either the springs or firing pin or something replaced.

ANY help is greatly appreciated.

Thanks,
Evo

evo9guy 04-30-2010 01:04 PM

Anybody...?

CA357 04-30-2010 03:57 PM

I don't really have any idea. Have you removed the bolt and checked it? Perhaps give the rifle a good cleaning and lube? Maybe disassemble the bolt and take a look? Is there a burr or something in the breech area?

evo9guy 04-30-2010 05:05 PM

I have removed the bolt and disassembled and cleaned. The action was better but still not 100%.

CA357 04-30-2010 05:29 PM

In that case, maybe it's time to take it to a gunsmith?


All times are GMT. The time now is 05:29 PM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.