Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   .22 Rifle/Rimfire Discussion (http://www.firearmstalk.com/forums/f21/)
-   -   Ruger 10/22 Trigger Problems (http://www.firearmstalk.com/forums/f21/ruger-10-22-trigger-problems-8890/)

WhiteWolf4 12-02-2008 11:21 PM

Ruger 10/22 Trigger Problems
 
Fired my .22 for the first time today...Got two problems....in ten rounds the trigger froze and wouldn't pull(like the safty was on, but wasn't)...Just wondered if anyone else has had this problem....#2: Need a scope for my .22...With my eyes, the iron sights is not gonna get it....WhiteWolf

Ram Rod 12-03-2008 03:32 PM

So your 10/22 is brand new just out of the box?

WhiteWolf4 12-03-2008 10:51 PM

Yeah, brand new and 10 rds shot through it....I took it back to the store and he said it was the ammo...CCI Green Tag....I don't have faith in that diagnosis, butttt, I told him I would try some new ammo...so, he swapped out my green tag for another CCI...WhiteWolf

Txhillbilly 12-04-2008 02:39 AM

Whitewolf,I have read on another forum of another person had the same issue with his and it had to be sent back to the factory and they sent him a new gun. It has to do with the trigger/safety setup in the trigger assembly.

Ram Rod 12-04-2008 01:53 PM

Quote:

Originally Posted by Txhillbilly (Post 54055)
Whitewolf,I have read on another forum of another person had the same issue with his and it had to be sent back to the factory and they sent him a new gun. It has to do with the trigger/safety setup in the trigger assembly.

Now that makes more sense to me. A pin or a spring isn't in the right spot or assembled correctly. Send it back to the factory through your dealer, or have your dealer swap you out and let them worry about the warranty.

WhiteWolf4 12-13-2008 03:51 AM

Thanks for the info...TxHillbilly....Yeah, thought it had to do with something like that...Maybe it wouldn't cock everytime or something...I'll check it out....Thanks again...WhiteWolf

stalkingbear 12-29-2008 04:47 PM

Sorry for being so late to post, it sounds like either the trigger isn't returning to forward position, or the hammer isn't staying cocked, and following the bolt forward. Either condition is virtually unheard of in factory, untouched rifles. In fact, I've never even heard of it happening in an factory stock rifle.

WhiteWolf4 12-30-2008 06:17 PM

Thanks Stalkingbear....I haven't had a chance to check it during the holidays...So, gonna take it out soon and see what happens...Thanks for the info...WhiteWolf

Meleniumx 03-06-2013 05:59 PM

Just got a brand new 1022 and experienced the same problem. Called Ruger and they said to ship it back to them.

Garadex 03-06-2013 10:16 PM

Quote:

Originally Posted by Meleniumx (Post 1166078)
Just got a brand new 1022 and experienced the same problem. Called Ruger and they said to ship it back to them.

Four birthday cakes.


All times are GMT. The time now is 06:53 PM.

Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.