Firearm & Gun Forum - FireArmsTalk.com > Long Guns > Auto & Semi-Auto Discussion > AR-15 Discussion > strange problem with new build

Reply
 
LinkBack Thread Tools Display Modes
Old 10-07-2011, 05:53 AM   #1
Feedback Score: 0 reviews
 
Nathantc's Avatar
 
Join Date: Sep 2011
Location: Lumberton,Texas
Posts: 560
Liked 41 Times on 32 Posts
Likes Given: 70

Default strange problem with new build

OK I have tried milspec gi mags, they work fine, and magpul """30rd""" mags work fine.

This odd issue I am having is only with magpul """20rd"""mags, they will not activate the last round bolt hold open. I have 10 gi mags they all work, 4 30rd pmags they all work, but the 4 20rd pmags I have will not hold the bolt open.

Maybe some one can shed some light on this

With the 20rd mags I have to smack the bolt release very hard to get it to let go, also with the mag inserted on a closed bolt if I pull the charging handle back and use the bolt hold open manually it is very hard to move and make a loud click when it breaks free.

the 20rd mags work just fine in my bull barrel ASA AR-15, just fyi





__________________
Nathantc is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 10-07-2011, 03:28 PM   #2
Feedback Score: 0 reviews
 
fsted2a's Avatar
 
Join Date: Apr 2008
Posts: 968
Liked 152 Times on 125 Posts
Likes Given: 206

Default

Could be a batch of magazines with bad followers.



__________________
fsted2a is offline  
 
Reply With Quote
Old 10-07-2011, 03:36 PM   #3
Feedback Score: 0 reviews
 
Nathantc's Avatar
 
Join Date: Sep 2011
Location: Lumberton,Texas
Posts: 560
Liked 41 Times on 32 Posts
Likes Given: 70

Default

they work fine in my other ar15, they also work just fine in my buddies other 3 ar15's, we actually just got done testing that.

it seem like the bolt catch is binding, but only with these mags.

its not that big of a deal being as i will only be useing 30rders in this one but i cant help but want to know whats going on

__________________
Nathantc is offline  
 
Reply With Quote
Old 10-07-2011, 04:13 PM   #4
Feedback Score: 0 reviews
 
fsted2a's Avatar
 
Join Date: Apr 2008
Posts: 968
Liked 152 Times on 125 Posts
Likes Given: 206

Default

Quote:
Originally Posted by Nathantc View Post
they work fine in my other ar15, they also work just fine in my buddies other 3 ar15's, we actually just got done testing that.

it seem like the bolt catch is binding, but only with these mags.

its not that big of a deal being as i will only be useing 30rders in this one but i cant help but want to know whats going on
Try swapping out uppers between your AR's to see if the problem is in your upper or lower. You can use the charging handle to similate firing for this purpose. My bet is it is in the lower. If so, try a micrometer or caliper on the mag well to see if you can find where the dimensions are different. If the magwell is binding, you can usually take a file to the spot that is binding and cure the problem if you don't take too much material off. If it is in the upper, which is less likely, it probably is in the extractor.
__________________
fsted2a is offline  
 
Reply With Quote
Old 10-07-2011, 04:34 PM   #5
Feedback Score: 0 reviews
 
Nathantc's Avatar
 
Join Date: Sep 2011
Location: Lumberton,Texas
Posts: 560
Liked 41 Times on 32 Posts
Likes Given: 70

Default

its the lower for sure, i just dont see what the differnce is between the 20 and 30rd mags

__________________
Nathantc is offline  
 
Reply With Quote
Old 10-07-2011, 09:29 PM   #6
Feedback Score: 0 reviews
 
Quentin's Avatar
 
Join Date: Apr 2010
Location: Idaho
Posts: 6,246
Liked 730 Times on 541 Posts
Likes Given: 699

Default

Seems like the bolt catch lever would be high on the list of culprits. I'd compare it closely against on in the other lowers that work with 20rders.

If that's it, it's a cheap fix so probably a good idea to replace it since both types of mags are important.

__________________

The biggest issue with assembling an AR isn't so much getting the parts together right - it's getting the right parts together.
You'll remember the quality of a gun long after you forget how much you paid for it.
________________________________________
US Army 1966-69, VFW Life Member, Retired Geek

Quentin is offline  
 
Reply With Quote
Old 10-07-2011, 10:39 PM   #7
Feedback Score: 0 reviews
 
Blackbeard1718's Avatar
 
Join Date: Oct 2010
Location: Texas Hill Country!
Posts: 181
Liked 8 Times on 7 Posts
Likes Given: 16

Default

Hmmm! I use nothing but the PMAG 20-Rounders with the same Black Follower, and haven't had any problems..... Knock-On-Wood!

I have an RRA Tac Op 2, and the Mags Load/Eject just fine.

Best of Luck!

Cheers!

BB

__________________
Blackbeard

"The Floggings will continue, until Morale improves!"
Blackbeard1718 is offline  
 
Reply With Quote
Old 10-08-2011, 12:00 AM   #8
Feedback Score: 0 reviews
 
Nathantc's Avatar
 
Join Date: Sep 2011
Location: Lumberton,Texas
Posts: 560
Liked 41 Times on 32 Posts
Likes Given: 70

Default

i dont think its the mags, though i cant see why the 30rd mags work and the 20 dont.

the 20rd mags i have work in many other lowers, just not this one.

__________________
Nathantc is offline  
 
Reply With Quote
Old 10-11-2011, 01:42 PM   #9
Feedback Score: 0 reviews
 
fsted2a's Avatar
 
Join Date: Apr 2008
Posts: 968
Liked 152 Times on 125 Posts
Likes Given: 206

Default

Quote:
Originally Posted by Nathantc View Post
i dont think its the mags, though i cant see why the 30rd mags work and the 20 dont.

the 20rd mags i have work in many other lowers, just not this one.
Have you taken a caliper or micrometer and measured the 20 rd mags? Sometimes a batch from an otherwise reputable manufacturer can be off a little. Doesn't take much. Just going by process of elimination. Stands to reason that if other mags work fine, and the 20 rounds don't, you might want to check the measurements. It doesn't take but a thousanths to mean the difference between working fine, and causing problems. If a GI issue works good, it probably is the mags. Even the best have some lemons.
__________________
fsted2a is offline  
 
Reply With Quote
Old 05-28-2013, 12:06 AM   #10
CGS
Feedback Score: 0 reviews
 
Join Date: Mar 2013
Location: Chicago Illinois area
Posts: 378
Liked 66 Times on 52 Posts
Likes Given: 2

Default

Download each mag by one? I have a batch of magpul mags where I can load 31 rounds. If I do the mag will not latch into place. This is fairly common with the gen 2 Pmags.



__________________

-Thomas
NRA Life Member, ISRA Member, American Gunsmith Institute Certified, NRA Instructor, State of IL authorized Carry Concealed Instructor http://www.chicagogunsmith.com
http://www.firearmtrainingchicago.com

CGS is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
Japanese are strange. Shihan The Club House 42 02-10-2011 03:59 AM
Snap Caps problem? or gun/shooter problem? jtaylor418 1911 Forum 5 03-03-2010 02:06 AM