new build, having issues - Page 3
You are Unregistered, please register to use all of the features of!    

Firearm & Gun Forum - > Long Guns > Auto & Semi-Auto Discussion > AR-15 Discussion >

new build, having issues

LinkBack Thread Tools Display Modes
Old 03-07-2013, 05:29 PM   #21
Feedback Score: 0 reviews
purehavoc's Avatar
Join Date: Oct 2011
Location: Not where I wanna be
Posts: 4,822
Liked 1164 Times on 755 Posts
Likes Given: 2050


Originally Posted by boudmanj View Post
Tried three different buffers, same result, my gas block leaks, carbon on the hand guards, and I just found out my gas tube is bad from the guy I got it from, didn't pay anything for it thank god
Yeah thats a bum deal , get her fixed up and try again . thats all you can do

purehavoc is offline  
Reply With Quote
Old 03-07-2013, 08:14 PM   #22
Feedback Score: 0 reviews
Join Date: Mar 2013
Posts: 31
Liked 3 Times on 3 Posts


Good news, after a new low pro gas block and new tube, it cycles great, buffer is barely to heavy, won't lock on empty, but thats an easy fix

Thanks for all the input and help y'all

Shoot on!!!
boudmanj is offline  
Reply With Quote

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
Girlfriend/wife issues/boyfriend/ husband issues with guns? haha 94browninghunt The Club House 69 01-13-2013 08:04 AM
11-48 issues virginiashooter General Shotgun Discussion 0 12-11-2012 04:04 AM
10 rnd mag issues psymmonds 1911 Forum 8 09-03-2012 10:09 PM
10/22 issues Badshot320 .22 Rifle/Rimfire Discussion 5 08-06-2012 08:52 PM
New AR issues TheDaggle AR-15 Discussion 16 07-10-2010 04:02 PM

Newest Threads