AR-15 problem trigger
You are Unregistered, please register to use all of the features of FirearmsTalk.com!    


Firearm & Gun Forum - FireArmsTalk.com > Long Guns > Auto & Semi-Auto Discussion > AR-15 Discussion >

AR-15 problem trigger


Reply
 
LinkBack Thread Tools Display Modes
Old 03-01-2010, 10:22 PM   #1
Feedback Score: 0 reviews
 
Join Date: Feb 2010
Posts: 13
Default AR-15 problem trigger

i just put in a new rock river 2 stage trigger and ive got about 200 rounds through with it but its been hanging and i have no clue how to fix it any info and help would be great


SeanTLog is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 03-01-2010, 10:29 PM   #2
Feedback Score: 0 reviews
 
Join Date: Oct 2009
Posts: 29
Default Trigger Job

What does hanging up mean to you.

What are you observing and what is the trigger doing or not doing?

JM


jmac2387 is offline  
 
Reply With Quote
Old 03-01-2010, 11:11 PM   #3
Feedback Score: 0 reviews
 
DrumJunkie's Avatar
 
Join Date: Feb 2010
Location: Here in the holler....
Posts: 4,823
Liked 1617 Times on 945 Posts
Likes Given: 1894

Default

Not resetting?
DrumJunkie is offline  
 
Reply With Quote
Old 03-01-2010, 11:28 PM   #4
Feedback Score: 0 reviews
 
stalkingbear's Avatar
 
Join Date: Sep 2007
Location: Bloomfield,Ky
Posts: 3,767
Liked 114 Times on 79 Posts
Likes Given: 43

Default

Are you SURE you have the spring in right?
__________________
Sometimes you earthlings REALLY amaze me!
stalkingbear is offline  
 
Reply With Quote
Old 03-02-2010, 12:01 AM   #5
Feedback Score: 0 reviews
 
Join Date: Feb 2010
Posts: 13
Default

when i got to pull the trigger back after a shot it feels like its catching on something and when i pull it a few times ill will give im clueless as to what i might need to do i dont think its in wrong because it will run flawless for a few rounds sometimes
SeanTLog is offline  
 
Reply With Quote
Old 03-02-2010, 12:14 AM   #6
Feedback Score: 0 reviews
 
deth502's Avatar
 
Join Date: Apr 2008
Posts: 137
Default

first thing id do would be to disassemble and clean it.

first, the "dragging on something" intermittently tell me that theres a good chance its just some dirt in there, and if not, the disassembly will also reassure you that youve put everything in correctly.
deth502 is offline  
 
Reply With Quote
Old 03-02-2010, 12:26 AM   #7
Feedback Score: 0 reviews
 
Join Date: Feb 2010
Posts: 13
Default

well see the thing is it did it the 1st time i put it in. i took it out greased it real well put it back in and you would go to pull the trigger and it wouldnt. pull it a few times and for no reason nothing different it would release and that was before it had its cherry popped. Could it have anyhting to do with the ambi saftey selector i installed?

Last edited by SeanTLog; 03-02-2010 at 12:32 AM.
SeanTLog is offline  
 
Reply With Quote
Old 03-02-2010, 01:31 AM   #8
Feedback Score: 0 reviews
 
deth502's Avatar
 
Join Date: Apr 2008
Posts: 137
Default

try it with the safety removed to determine that
deth502 is offline  
 
Reply With Quote
Old 03-03-2010, 05:42 PM   #9
Feedback Score: 0 reviews
 
Join Date: Feb 2010
Posts: 13
Default

i appreciate yalls input it turned out to be the ambi saftey i have no idea why the ambi saftey would hangup the trigger but anyways i put the standard saftey selector back in and it is operating flawlessly. while i had the trigger assembly out i polished it up wth my dremel and it sweetened up the the trigger pull made it very crisp
SeanTLog is offline  
 
Reply With Quote
Old 03-07-2010, 05:44 PM   #10
Feedback Score: 0 reviews
 
Join Date: Feb 2010
Posts: 13
Default

ok so i still have the problem but i figured out if you push the trigger forward after the shot it works fine. it makes a clicking sound when its pushed forward like its locking in. and its doing it every shot a real pain in the ass when trying to shoot. anyone ever had this problem


SeanTLog is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
XDM Problem trigem XD Forum 9 03-20-2010 01:52 PM
I'm JD & I Don't Have A Problem! Dillinger The Club House 22 09-30-2009 04:02 AM
Kahr trigger vs. Glock trigger CHLChris Semi-Auto Handguns 0 07-25-2009 11:58 PM
any of you had this problem divingfroggy Semi-Auto Handguns 4 05-05-2009 03:07 PM
SKS Problem stuii AK & SKS Discussion 8 07-01-2008 01:55 AM



Newest Threads