300 blackout ejection problems
Firearm & Gun Forum - FireArmsTalk.com > Long Guns > Auto & Semi-Auto Discussion > AR-15 Discussion > 300 blackout ejection problems

Reply
 
LinkBack Thread Tools Display Modes
Old 08-23-2013, 08:56 PM   #1
Feedback Score: 0 reviews
 
Join Date: Jul 2013
Posts: 5
Default 300 blackout ejection problems

300 blackout having problems ejecting round fully before next round trying to load. Shot 3 times with same result.

__________________
Deuce31378 is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 08-23-2013, 10:47 PM   #2
Supporting Member
FTF_SUPPORTER.png
Feedback Score: 0 reviews
 
Sniper03's Avatar
 
Join Date: Jun 2010
Location: Tennessee
Posts: 5,383
Liked 2722 Times on 1327 Posts
Likes Given: 1386

Default

Deuce,
Tell us more! Did you purchase this upper or build it? Was a Weaver style gas block installed on it? Does it have an M-4 Cut barrel cut on it? Are you shooting full power ammunition or sub sonic? What stock and buffer do you have on it?

03

__________________

The Constitution is not an instrument for the Government to restrain the people. It is an instrument for the people to restrain the Government!
*Patrick Henry

Today, we need a nation of Minutemen, citizens who are not only prepared to take arms, but citizens who regard the preservation of freedom as the basic purpose of their daily life and who are willing to consciously work and sacrifice for that freedom."

-- John F. Kennedy

Sniper03 is offline  
 
Reply With Quote
Old 08-24-2013, 01:43 AM   #3
Feedback Score: 0 reviews
 
Join Date: Jul 2013
Posts: 5
Default

Quote:
Originally Posted by Sniper03
Deuce,
Tell us more! Did you purchase this upper or build it? Was a Weaver style gas block installed on it? Does it have an M-4 Cut barrel cut on it? Are you shooting full power ammunition or sub sonic? What stock and buffer do you have on it?

03
I built it. It has a low profile gas block. It was built as a pistol, so it has a 10" barrel and pistol buffer tube kit. I was shooting full power ammo.
__________________
Deuce31378 is offline  
 
Reply With Quote
Old 08-24-2013, 02:02 AM   #4
Feedback Score: 0 reviews
 
duddie10's Avatar
 
Join Date: Jan 2013
Location: Connecticut
Posts: 517
Liked 85 Times on 70 Posts
Likes Given: 1

Default

Could be a buffer issue. Sounds like its not cycling fully.

__________________

you pew pew pew lately bro!?

duddie10 is offline  
 
Reply With Quote
Old 08-24-2013, 04:34 AM   #5
Moderator
FTF_MODERATOR.png
Feedback Score: 1 reviews
 
robocop10mm's Avatar
 
Join Date: Jul 2007
Location: Austin,Texas, by God!!
Posts: 10,316
Liked 2983 Times on 1554 Posts
Likes Given: 275

Default

What buffer? Weight? Spring? Could be under gassed.

Does it cycle manually?

__________________

In life, strive to take the high road....It offers a better field of fire.
"Robo is right" Fuzzball

robocop10mm is offline  
purehavoc Likes This 
Reply With Quote
Old 08-24-2013, 12:01 PM   #6
Feedback Score: 0 reviews
 
Join Date: Jul 2013
Posts: 5
Default

Quote:
Originally Posted by robocop10mm
What buffer? Weight? Spring? Could be under gassed.

Does it cycle manually?
The pistol kit came with carbine spring and weight.
__________________
Deuce31378 is offline  
 
Reply With Quote
Old 08-24-2013, 12:07 PM   #7
Feedback Score: 0 reviews
 
duddie10's Avatar
 
Join Date: Jan 2013
Location: Connecticut
Posts: 517
Liked 85 Times on 70 Posts
Likes Given: 1

Default

Quote:
Originally Posted by Deuce31378 View Post

The pistol kit came with carbine spring and weight.
What kit is it? The buffer has a weight etched on it. Its hard to diagnose a problem with little info. How about a detailed list of your whole build. Lets start at square one.
__________________

you pew pew pew lately bro!?

duddie10 is offline  
purehavoc Likes This 
Reply With Quote
Old 08-24-2013, 12:33 PM   #8
Feedback Score: 0 reviews
 
purehavoc's Avatar
 
Join Date: Oct 2011
Location: Not where I wanna be
Posts: 4,750
Liked 1133 Times on 737 Posts
Likes Given: 2021

Default

Quote:
Originally Posted by Deuce31378 View Post
The pistol kit came with carbine spring and weight.
Are u 100% sure hour gas block is lined up with the hole ? Move your gas block back 1/16 " and try it again. Most barrels are drilled so that there is enough spacing for the hand guard attachment between the flat and the gas block . Measure how long the buffer spring is . They could have sent a rifle length spring which will cause this. How long is the buffer tube ? And most importantly before u do any of the above did you lube up the bcg well ?
__________________
Criminals Prefer Unarmerd Victims....


And Dictators Prefer Unarmed Citizens
purehavoc is offline  
 
Reply With Quote
Old 09-13-2013, 01:17 PM   #9
Feedback Score: 0 reviews
 
Join Date: Jul 2013
Posts: 5
Default

*UPDATE*

Problem solved. Switched to a heavy buffer and had to replace a faulty gas key. Fires without fault now. Thanks for all the help

__________________
Deuce31378 is offline  
 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
Remington 870 ejection problems Rockjeep94 General Shotgun Discussion 11 03-30-2013 04:46 AM
Extractor/ejection Problems curleymoe General Handgun Discussion 6 04-19-2012 07:04 AM
M&P Ejection Clearance E-Rez Semi-Auto Handguns 2 07-24-2010 09:14 PM
Ruger 22/45 ejection problems Jesse17 Semi-Auto Handguns 1 07-17-2009 03:37 PM
Mini 14 ejection giz189 General Rifle Discussion 9 03-12-2009 04:41 PM