My ak-47 keeps jamming!!??
You are Unregistered, please register to use all of the features of!    
Firearm & Gun Forum - > Long Guns > Auto & Semi-Auto Discussion > AK & SKS Discussion >

My ak-47 keeps jamming!!??

Closed Thread
LinkBack Thread Tools Display Modes
Old 03-26-2011, 06:29 PM   #1
Feedback Score: 0 reviews
Join Date: Feb 2011
Location: Katrina hit here,MISSISSIPPI
Posts: 5
Default My ak-47 keeps jamming!!??

hey folks, I recently purchased and inner ordinance (I.O.) AK-47 about a month ago, I bought about 200 hundred rounds of WOLF ammo with it. i have slung all 200 rounds through it but, It jams about 3-5 times per 30 round clip, that pisses me off because i want perfection, especially if someones threatining my life or my families life in a dier emergency. I've cleaned the gun every time after i shoot it, oil the gun, piston, chamber, etc etc. Ive heard from different people it could be the WOLF ammo, could that be true?? I hear alot of good things about Yugo ammo. I wanna know for sure before i buy 1000 rounds of Yugo ammo and the same thing keeps happening, either way i have a lifetime warranty on the firearm, worse come to worse ill kiss it goodbye. Thanks for the help.

Last edited by Megahonky89; 03-26-2011 at 06:35 PM.
Megahonky89 is offline  

Join Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join Today! - Click Here

Old 03-26-2011, 06:52 PM   #2
Feedback Score: 0 reviews
VitSports6's Avatar
Join Date: Nov 2009
Location: Taylorsville,Utard
Posts: 744
Likes Given: 2


what kind of magazines are being used?
some ammo has a coating that can cause jamming.
best of luck
Have fun
VitSports6 is offline  
Old 03-26-2011, 07:32 PM   #3
Feedback Score: 0 reviews
Join Date: Feb 2011
Location: Katrina hit here,MISSISSIPPI
Posts: 5

im using tapco magazines, with the big springs in them, its feeding the bullets in correctly, jus not ejecting the casing fully out the chamber, causing the action to stay open and not eject another.. unless i manually pull the chamber back to eject it myself.. not something i want to happen if im gettin shot at lol
Megahonky89 is offline  
Old 03-26-2011, 10:04 PM   #4
Feedback Score: 0 reviews
orangello's Avatar
Join Date: Feb 2009
Posts: 19,154
Liked 5738 Times on 3362 Posts
Likes Given: 4877


Have you cleaned the gas tube & gas port that power the ejecting portion of the firing cycle? I wouldn't use much oil there, nasty environment. Have you examined the part of the bolt that grabs the bullet's base to eject it to see that it looks OK (looks like a half claw on my SKS, can't remember on the WASR)?

Wolf runs fine in my buddy's WASR10/AK clone and in my SKS.
Dead Bears, the only good kind.
orangello is offline  
Old 03-26-2011, 10:18 PM   #5
Feedback Score: 0 reviews
Join Date: Feb 2011
Location: Katrina hit here,MISSISSIPPI
Posts: 5

Yea ive cleaned and checked everything, the sad part is that MOFO is only about two months old and only shot about 200 rounds. its too new for all that bs to happen.
Megahonky89 is offline  
Old 03-27-2011, 02:26 AM   #6
Feedback Score: 0 reviews
HighPlainsDrifter's Avatar
Join Date: Oct 2010
Location: Phoenix,Arizona
Posts: 178

It sounds like your not getting enough pressure to blow the bolt carrier back enough. If you have cleaned the gas tube already then try taking a paper clip and sticking it in the little hole in the gas block that goes down to barrel. It could be stuffed up from shooting that wolf ammo. If it doesn't help then switch ammo I have never had good luck with wolf ammo, go with brown bear basically same price for much better ammo. Hope this helps.
A person who owns a firearm is a free man,A person who dosen't is a slave to there Country.Think about it.
HighPlainsDrifter is offline  
Old 03-27-2011, 04:01 AM   #7
Feedback Score: 0 reviews
Bushman's Avatar
Join Date: Jan 2011
Location: Seaside,Oregon
Posts: 168

Definitely check your gas port, like HPD suggested. All I've shot through my AK has been wolf. No problems ever. I think it's your rifle, not the ammo.
Bushman is offline  
Old 03-27-2011, 08:16 AM   #8
Feedback Score: 0 reviews
M14sRock's Avatar
Join Date: Oct 2008
Location: Los Angeles
Posts: 5,543
Liked 38 Times on 27 Posts
Likes Given: 49


Wolf and AKs are like peas and carrots.


"Obama has ordered the launching of more Tomahawk cruise missiles than All the other Nobel Peace Prize winners combined."
M14sRock is offline  
Old 03-27-2011, 10:55 PM   #9
Feedback Score: 0 reviews
diggsbakes's Avatar
Join Date: Jul 2009
Location: Pueblo,Colorado
Posts: 1,680
Liked 8 Times on 5 Posts


Wolf is one of many Steel-cased, Russian ammo that I shoot out of my AKs. . . and while I prefer others (Brown Bear, Golden Tiger and especially Yugo Surp) for slightly better results, Wolf ALWAYS shoots well . . . and should!

An AK should eat everything! I'm not familiar with Inter-Ordinance, but this is definitely a rifle problem. I also do not like Tapco (anything, but especially) magazines. Get you some used military surplus steel mags and don't look back. Bulgarian, Yugo, Eastern German, Romanian, Russian and many others ALL make great 30 and 40 round mags. Heck, even China has some good ones out there.

Like was said before check everything from your gas port to your piston. There is a chance corrosion could be blocking proper flow, to be sure, drop some "Sweet's 7.62 solvent" down the gas port with the tube off. While it is off inspect the tube for signs of corrosion. Give everything a good cleaning and re-assemble and lube the heck out of it. It should shoot fine. If not, then go for help or take the gun back.

No AK should EVER fail ! ! !
diggsbakes is offline  
Old 03-27-2011, 11:28 PM   #10
Supporting Member
Feedback Score: 0 reviews
Sniper03's Avatar
Join Date: Jun 2010
Location: Tennessee
Posts: 6,443
Liked 3919 Times on 1892 Posts
Likes Given: 1970



When you first got it! Did it work properly then and for a period of time before you started experiencing a problem?

Sniper03 is offline  
Closed Thread

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
my xdm 40 is jamming. joshmb1982 XD Forum 31 10-20-2009 05:52 AM
how to keep XDM from jamming martyj General Handgun Discussion 27 04-17-2009 10:28 AM
HK SL8-6 Jamming Chuck_N Auto & Semi-Auto Discussion 3 03-21-2009 12:59 AM
Jamming Handyman Gunsmithing Forum 6 01-22-2009 02:03 AM
870 Jamming notdku General Shotgun Discussion 1 06-03-2007 12:16 AM

Newest Threads