Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   AK & SKS Discussion (http://www.firearmstalk.com/forums/f19/)
-   -   another sks another question (http://www.firearmstalk.com/forums/f19/another-sks-another-question-98268/)

Drkuhar 10-07-2013 01:25 AM

another sks another question
 
I got a second sks on trade tonight. It has the horrible ati combat exchange folding stock on it. And this one has a issue.
The bolt will not lock back. Seller said it fired fine but was a pain to load (original 10 rd toploader). What do I look for that could cause the bolt to not lock

sigman84 10-07-2013 01:49 AM

Check to make sure the follower or the little tab that locks the bolt back haven't been modified or damaged.

SSGN_Doc 10-07-2013 02:24 AM

Check for the things listed above as well as to see if the POS stock is binding any parts and preventing them from traveling fully.

Possible whoever used the stock, modified the parts to fit the stock or removed parts instead if modifying the stock.

One more reason I prefer leaving SKSs in their original form and furniture.

Does it have the original mag or is there a new "improved" mag installed that could be adding the suck to the rifle?

TDS92A 10-07-2013 08:42 PM

Good advice offered here. :D

Quote:

Originally Posted by sigman84 (Post 1394309)
Check to make sure the follower or the little tab that locks the bolt back haven't been modified or damaged.

Quote:

Originally Posted by SSGN_Doc (Post 1394351)
Check for the things listed above as well as to see if the POS stock is binding any parts and preventing them from traveling fully.

Possible whoever used the stock, modified the parts to fit the stock or removed parts instead if modifying the stock.

One more reason I prefer leaving SKSs in their original form and furniture.

Does it have the original mag or is there a new "improved" mag installed that could be adding the suck to the rifle?


Drkuhar 10-08-2013 11:08 AM

I broke the gun down to clean and inspect it. The tab that slides up and down for the bolt stop was stuck and wouldn't move. I kept tapping on it till it freed up and lubed everything and it works fine now


All times are GMT. The time now is 03:04 PM.

Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.