Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   General Rifle Discussion (http://www.firearmstalk.com/forums/f18/)
-   -   mauser spanish m43 7x57 mauser fixing question (http://www.firearmstalk.com/forums/f18/mauser-spanish-m43-7x57-mauser-fixing-question-91551/)

bluebikerboy1 05-31-2013 06:46 PM

mauser spanish m43 7x57 mauser fixing question
 
Gun is as discribed. on the bolt the lever on the end if put upright or to the right seems to be the safety. all the way to the left is fire. i was shooting newer winchester i think 7mm mauser ammo. gun did get real hot after about 10 rounds. then the darnest thing happened. i chambered a new round with the bolt and go to press the trigger and nothing. it was acting like the safety was on. i pulled the bolt slightly and slamed it in hard and locked in place and nothing. i messed with teh safety right to left and nothing. seemed i waited a few moments and it fired. after about 4 of these in a row i packed it up. have you heard of these old rifles doing this? was there something wrong with teh rifle or was it just to hot and something expanded due to the heat? any fixes for this?
thanks

SSGN_Doc 05-31-2013 08:02 PM

Make sure the firing pin channel is clean and free of gunk that could be melting and gumming up the firing pin if it gets hot.

hiwall 05-31-2013 08:07 PM

I agree with SSGN_Doc. Sounds like all you need is to disassemble and clean.


All times are GMT. The time now is 06:19 PM.

Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.