ATI Mosin Feeding Issue


Firearm & Gun Forum - FireArmsTalk.com > Long Guns > General Rifle Discussion > ATI Mosin Feeding Issue

Reply
 
LinkBack Thread Tools Display Modes
Old 07-20-2014, 05:57 AM   #1
Feedback Score: 0 reviews
 
Join Date: Jun 2014
Posts: 5
Liked 1 Times on 1 Posts

Default ATI Mosin Feeding Issue

Hey guys, so I got myself an ATI stock for my mosin 91/30 and had to shave off quite a bit, the original problem was I couldn't close the bolt (which has been fixed) but now the gun wont feed, and the bolt wont eject any of the brass except for the last one. If you could show me pictures that would be great too. thanks.



__________________
barkre14 is offline  
 
Reply With Quote

Join FirearmsTalk.com Today - It's Free!

Are you a firearms enthusiast? Then we hope you will join the community. You will gain access to post, create threads, private message, upload images, join groups and more.

Firearms Talk is owned and operated by fellow firearms enthusiasts. We strive to offer a non-commercial community to learn and share information.

Join FirearmsTalk.com Today! - Click Here


Old 07-22-2014, 12:01 PM   #2
FTF_SUPPORTER.png
Feedback Score: 0 reviews
 
John_Deer's Avatar
 
Join Date: Nov 2012
Location: North Carolina
Posts: 6,413
Liked 2142 Times on 1470 Posts
Likes Given: 796

Default

Did the gun work before you sporterized it? I don't mean did you cycle a couple magazines though the action. Did you take it out and shoot it several hundred times?



__________________

To argue with a person who has renounced the use of reason is like administering medicine to the dead. Thomas Paine

John_Deer is offline  
 
Reply With Quote
Old 07-24-2014, 05:25 AM   #3
Feedback Score: 0 reviews
 
Join Date: Jun 2014
Posts: 5
Liked 1 Times on 1 Posts

Default

When I first got it the gun ran like a champ, there was not a single misfire/malfunction in the 200+ rounds I shot through it.

__________________
barkre14 is offline  
 
Reply With Quote
Old 07-24-2014, 02:27 PM   #4
The Apocalypse Is Coming.....
Feedback Score: 0 reviews
 
Join Date: Aug 2011
Posts: 28,709
Liked 21994 Times on 12402 Posts
Likes Given: 53672

Default

Quote:
Originally Posted by barkre14 View Post
Hey guys, so I got myself an ATI stock for my mosin 91/30 and had to shave off quite a bit, the original problem was I couldn't close the bolt (which has been fixed) but now the gun wont feed, and the bolt wont eject any of the brass except for the last one. If you could show me pictures that would be great too. thanks.
quite possible you have magazine issue with the ATI stock of some sorts. try putting the action back in the original stock and see if the problem is fixed. if so, then something about the ATI stock is causing a feed issue that needs to be corrected. some sort of interference with the magazine, the follower or the magazine spring.
__________________
Axxe55 is offline  
Highpower Likes This 
Reply With Quote
Old 07-24-2014, 05:37 PM   #5
Feedback Score: 0 reviews
 
Highpower's Avatar
 
Join Date: Oct 2009
Location: Upper Mississippi Valley
Posts: 1,547
Liked 357 Times on 201 Posts
Likes Given: 292

Default

Quote:
Originally Posted by Axxe55 View Post
..... try putting the action back in the original stock and see if the problem is fixed.
That is some excellent advice right there....

Quote:
Fits Most 91/30 Rifles & M-38, M-44 Carbines and Mosin Nagant Variants 7.62x54R
Note: Sling Swivel Studs Accepts ATI's Sling Swivel (Part # A.5.10.2506) or any Standard Sling Swivel

Note: Some Minor Modification may be Required
I would venture a guess that your new stock needs "some" more modifications in other areas as well.
__________________
Highpower is offline  
Axxe55 Likes This 
Reply With Quote
Old 07-27-2014, 06:06 AM   #6
Feedback Score: 0 reviews
 
Geronimo's Avatar
 
Join Date: Jul 2014
Posts: 1
Liked 1 Times on 1 Posts
Likes Given: 1

Default

on the left hand side of your rifle barrel assembly when you take it apart you will see a small flat spring that needs to be able to move. On the ATI stock it seems that they did not take this into account when they made the mold for the stock. You will have to take a dremel tool and grind away part of the stock where it is up against and not allowed to move. I had to remove quite a bit of material out of mine in that area and now it functions like it should.... I hope that helps.

__________________

Reload your Berdan primered Cartridges!! Convert them to Boxer Primers! To find out how go to www.russianreloads.com

Geronimo is offline  
Axxe55 Likes This 
Reply With Quote
Old 07-27-2014, 08:56 AM   #7
The Apocalypse Is Coming.....
Feedback Score: 0 reviews
 
Join Date: Aug 2011
Posts: 28,709
Liked 21994 Times on 12402 Posts
Likes Given: 53672

Default

Quote:
Originally Posted by Geronimo View Post
on the left hand side of your rifle barrel assembly when you take it apart you will see a small flat spring that needs to be able to move. On the ATI stock it seems that they did not take this into account when they made the mold for the stock. You will have to take a dremel tool and grind away part of the stock where it is up against and not allowed to move. I had to remove quite a bit of material out of mine in that area and now it functions like it should.... I hope that helps.
this is along the lines i was thinking of. something in the ATI stock causing a feed issue that wasn't present with the factory stock.

this is why i suggested putting the action back into the original stock and see if the problem was resolved and then, if so, a person would need to make a determination as to where the problem was with the ATI stock to fix the issue.
__________________
Axxe55 is offline  
 
Reply With Quote
Old 07-28-2014, 10:25 AM   #8
Feedback Score: 0 reviews
 
Rex in OTZ's Avatar
 
Join Date: May 2008
Location: NW AK
Posts: 1,016
Liked 113 Times on 81 Posts
Likes Given: 2

Default

Sounds like new stock is pressing on the ejector/ctg interruptor on the left side action is binding on the stock.


http://www.thehighroad.org/archive/index.php/t-529230.html

__________________

Last edited by Rex in OTZ; 07-28-2014 at 10:28 AM.
Rex in OTZ is offline  
 
Reply With Quote
Old 07-31-2014, 06:26 AM   #9
Feedback Score: 0 reviews
 
Join Date: Jun 2014
Posts: 5
Liked 1 Times on 1 Posts

Default

I shaved off more to the left side of the stock and took a closer look at the ejector and saw that it was quite worn, I replaced it and now it works good as new, thank you very much you guys. you were a big help.



__________________
barkre14 is offline  
Geronimo Likes This 
Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Firearms Forum Replies Last Post
Rock Island M5 double feeding issue. smithbs09 General Shotgun Discussion 1 04-15-2014 11:04 PM
Tula feeding issue 6920 TankTop AR-15 Discussion 15 03-14-2013 01:57 PM
M1 Garand feeding issue GunsmithCat Gunsmithing Forum 3 01-27-2013 03:33 AM
SKS feeding issue Nihilist88 AK & SKS Discussion 11 05-05-2012 03:59 PM
Feeding issue GonzoLonzo .22 Rifle/Rimfire Discussion 10 01-17-2012 05:43 PM