Firearm & Gun Forum - FireArmsTalk.com

Firearm & Gun Forum - FireArmsTalk.com (http://www.firearmstalk.com/forums/)
-   General Rifle Discussion (http://www.firearmstalk.com/forums/f18/)
-   -   AR-15 problems (http://www.firearmstalk.com/forums/f18/ar-15-problems-61340/)

texashunter 03-29-2012 05:29 AM

AR-15 problems
 
I'm having trouble with the bolt on my Rock River AR sticking, after you chamber a round and shoot it, the bolt freezes and is almost impossible to pull open. I have tried powered graphite and WD-40 which work for awhile, but after continuous shooting the problem arises again. Any ideas on how to avoid this?

russ1982 03-29-2012 05:41 AM

How old is the gun. Has it been shot a lot. It could be a number of problems. Check for a loose carrier key. Check your cam pin for unusual wear. Look at the bolt lugs see if there is any unusual wear. Is the bolt getting stuck or just not cycling. Look at the the portion of the gas tube that goes into the carrier key. It might not be aligned properly if it's not there will be unusual wear on one side of it. It is hard to diagnose a malfunction with out getting your hands on the rifle. Stupid question but is it clean? 90% of malfunctions are due to a dirty gun.

russ1982 03-29-2012 05:44 AM

Just reread ur post. Check the gas tube and carrier key. If they are not aligned properly the bolt carrier will bind up. Look for unusual wear marks on the gas tube it will show there before the key will.

Car54 03-29-2012 12:45 PM

WD-40 isn't a lube. Buy some good weapon lubricant. If nothing else is available, get some oil from your car's dipstick and use that on the bolt, and keep it slightly wet.

Properly clean the chamber and bore with a good cleaner.

Check for loose/properly staked screws in the carrier key. Check the rings on the bolt

Have you tried using different ammo, and what ammo are you using?

Snakedriver 03-29-2012 02:35 PM

Is this an AR you built or a complete rifle that you bought somewhere? Was it new or used when you got it?

Make sure the spring detent that holds the buffer into the receiver extension isn't draging on the back of the bolt bottom.

Also make sure your charging handle is installed right and not dragging on the bolt. It could even be bent some.

My RRA is smooth as silk, you obviously have something that's not right going on.


All times are GMT. The time now is 07:55 PM.

Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.